Zolo Liberty: How to use Google Assistant on a Samsung Galaxy?

Hi there,

the new Zolo Liberty (Z2001) has the ability to activate the respective voice assistant (e.g. Siri). However, on my Samsung Galaxy S7 it activates S-Voice - the assistant Samsung is providing. I don’t like to use S-Voice (because of limited features) and I would like to use the Google Assistant instead. But I cannot get it working. How can I do that?

I already tried disabling the S-Voice app (via settings -> apps -> deactivate). By doing so, no voice assistant is activated when I double tap the liberty.

I checked in the Google Assistant and the “listen on bluetooth” flag is enabled.

Any more ideas?

Thank you.


To my knowledge with the S7, you would have to use Google Now. Try going to Settings >> Applications >> 3 dots right up and pick Default apk … >> Device Assistance app and choose Google.

1 Like

Thank you for the quick reply.

However, that does not work on my phone. Regardless of what I choose as default device assistence app, a double tap on the Zolo will open S-Voice (or do nothing if I deactivate the app).

In short: did not work for me.

Any other ideas?

1 Like

Try the steps mentioned Here


Hope you get it figured out :thumbsup:

Hi @Tank, the link you mentioned describes a way to change the google assistant when pressing on the home button of your phone. The method does not work for the bluetooth functionality. Although there is another button involved (the button on your bluetooth headset), this button is not directly accessible in android (as far as I know).
So in the end, it does not solve my point. But am I the only one having this issue?

I don’t know what your talking about the button not being directly accessible in android as I use it daily with all my bluetooth headsets. I also have my phone set so I don’t have to press any buttons if my hands are not free and all I have to do is say “ok google” and it turns on Google assistant

Just went back and tried to activate Google via the left earbud of the liberty air and it did so right away. So I’m not sure why you are having issues.