Why does my apple iwatch series 4 not charge on anker 5 port

I have the anker 5 port desktop charger link below


When i put my apple watch series 4 on the 5port charger above it starts to charge and sometimes it stops. So in the morning its not fully charged. No problem charging with the original small apple charger that came with the iwatch.
I seen on the iwatch once that i noticed. It said this device isnt supported with this charger or something like that when it was plugged in the 5 port anker charger.
I had the iwatch charging wire plugged in the regular usb port not the fast charging ones that are blue.
I wasnt sure if i could use the fast charging ports(blue) for the iwatch cause i didnt want my iwatch to get damaged…
Some help please or if anyone has had this problem.
The charger is fairly new

1 Like

I dont know if the iwatch charger is apple certified, but apple watches need the chip in the charger to properly charge it. It’s like the mifi certified cables that use a chip to verify its approved to charge the device. And if your iwatch charger doesnt have it then the watch won’t charge properly regardless what charger you plug it into

My apple charger will charge the iwatch no problem. My anker 5port charger i posted above wont charge the iwatch. Well it starts and then stops and in the morning its not fully charged

1 Like

Sometimes when this happens to me, it’s because the back of the watch or the top of the charging puck is dirty… thus, it wasn’t contacting. Try wiping down the charging puck and the back of your watch. I always make sure I see the charging bolt icon and hear the chime before walking away after putting it on the charging puck. I haven’t had any problems using any of Anker’s PowerPort desktop chargers. Hope this helps. If not, contact support@anker.com . :slight_smile:

Ive tried cleaning both. Ive tried to restart the iwatch and i unplugged the charger for 5mins and still get this problem.

Do i have to have it plugged in the quick charging port? Or will that damage my iwatch?

I have no problem charging it with the original charger.
Im using the wire/ puck that came with the iwatch
Just when i try to use the 5 port anker charger i posted above it starts to charge i see the green lightning bolt and the sound goes. Then a few mins later it stops
Or if i walk up past it. It will start and stop

1 Like

That is strange. It kind of sounds like there is a short somewhere by what you are describing. My Apple Watch charges fine on my PowerPort 5, PowerPort Speed 5, and the PowerPort Speed PD. The only other thing to check would be the cable end, where you plug it into the PowerPort. Make sure there is no lint stuck inside it. Also check the PowerPort ports for the same. I would suggest trying with another charging puck but you said that it works fine with the original plug adapter. But if you have another charging puck, try it. If all my suggestions don’t get you any results, then contact support@anker.com . Sorry I couldn’t be more of assistance.

Thanks for your time and help