USB-C 13-in-1 - Nothing plugged into any display ports is recognized

I have tried setting up my new Anker USB-C 13-in-1 docking station and I cannot get my desktop or my laptop to recognize anything plugged into any of the display ports. I have two Acer monitors (model SA270), which have HDMI, DP, and USB-C ports. I’ve tried every combination of connecting every port from the monitors to the docking station and still nothing. I know the docking station is working on some level because both my desktop and my laptop immediately recognize the keyboard and mouse I have plugged into the docking station, but never any of the monitors, whether using the USB-C, Displayport, or HDMI inputs. They are an HP desktop and laptop, and I’ve checked and it seems all the drivers are updated. I also know it’s not the monitors themselves because they work fine when plugged directly into the laptop and desktop. Something is just going wrong between their connection to the USB-C docking station and the laptop/desktop. Do I have a defective unit or is there something I’m missing? I’ve never had a problem at all with an Anker product and this is a bit frustrating because it’s such an expensive docking station and I can’t get any monitors to work with it.

Have you gone into your computer settings and change the display output to either duplicate display or extend display?

So if I unplug a display from the docking station and plug a single monitor directly in, then I can go into the display output, but neither option is available because it does not recognize any additional displays besides the ones directly plugged in. So there’s no option to duplicate or extend displays because it doesn’t recognize the other displays, only the single one that is directly plugged in (not through the USB C docking station). The only way I get those options is to unhook all of the displays from the USB C docking station and plug them directly into the computer, then everything becomes available. That’s why it definitely seems like an issue with the docking station and not the displays or the computers because everything works until you introduce the docking station - then none of the displays are recognized.

I’m having the same issue. I just setup a brand new Lenovo Ideapad with a brand new Anker PowerExpand 13-in-1 USB-C Dock. Everything works, USB A, USB C, audio out, webcam, charging dock for my phone. BUT, the HDMI is not recognizing my monitor. When I plug the monitor in directly it works instantly.

So, the computer recognizes the monitor, but is NOT seeing it when plugged into the hub. I tried both HDMI inputs on the hub and neither work. The monitor does not support USB-C. So, I have to stick with HDMI. The cable is definitely working as it has no problem when plugged directly into the laptop.

Please try this, with everything plugged in go to your computer settings> appearance and personalization >display> choose identify displays…it should show whatever displays you have plugged in under identify display> click on whichever display that isn’t showing up> click multiple display and select extend to this display and click OK/save. You may need to repeat for each display not showing up initially.

Tank - I know how to do that but the problem is that the monitor is NOT showing up there. See Hamlet’s note above. I am having the same problem. The monitor is not showing up on the list. Works fine if i plug straight into the laptop, so it’s not the cable or the monitor or the laptop. The weak link is the Anker hub.

Does anyone know of a hard reset or some way to trigger the hub to look for the HDMI input all over again? I’ve tried powering cycling the monitor and the hub and neither worked.
If I’m only using one HDMI input, does it matter which one?
Is there an app do manage the hub? Do I need to update the firmware or something?

Is there sufficient power going to the hub?

I see it’s a DC powered hub so should be plenty of power.

I can’t see a support firmware upgrade.

It’s a relatively new and expensive hub so likely few owners here. Email support

1 Like

Thanks Professsor! :slight_smile: I’ve already done that, so we’ll see what they say.

1 Like

Bad news all! Lenovo Ideapad does NOT support Display through USB-C. Boohiss!!! I had to return the hub. Fortunately, I still have my old USB 3.0 Anker Hub. Still works great… :slight_smile:

1 Like

Thanks for letting us know, the reply is here for future searches.

Ideapad does not support HDMI over USBC.

Now you mentioned it, this is not a surprise, the fact the laptop has HDMI port means they didn’t need to also add the capability to the USBC port. If there wasn’t an included HDMI port then they’d have had a reason to spend the pennies to enable over USBC.

sounds very much like the problems I have experienced with the PowerExpand 12-in-1 media dock with power delivery. The external displays wont work until Power is unplugged from the dock. I recommend the OP contact Anker ASAP. maybe if others contact them, they’ll work on a better fix

In this case it’s unfixable by Anker. The laptop is not allowing it.

This is exactly what I found with a separate discussion with Anker support. Unless your laptop or desktop’s USB-C supports DP Alt Mode, then this is not going to work for displays. I didn’t know that when I bought the docking station but I know it now. Make sure you check that before you buy the USB-C 13-in-1 dock. I’m sure a lot of newer machines are set up that way, but mine are over two years old so they definitely aren’t. Chances are your manuals from them aren’t even going to mention DP Alt Mode if they are older because that probably wasn’t even a thing that existed.

1 Like