USB 3.0 to Ethernet Adapter only works like USB 2.0

Hello People,

i got an Anker USB 3.0 to Ethernet Adapter with the RTL8153 Chipset, since I made the Win 10 Upgrade from 1709 to 1803 respectively 1809 the Adapter only works like USB 2.0.
The Speed is only 42MB/s, before I had about 119MB/s. Downgrade doesn’t change anything, Windows 10 (64-bit) is completely new installed. I also Installed the official Driver for the Chipset from the Realtek site, all other connections like an USB-Stick worked fine in normal USB 3.0 Speeds so it doesn’t seems a Problem with the USB 3.0 Drivers on the Notebook. I don’t have another Adapter to Check if the Adapter itself has an Problem in the cable. Does anyone have the same Problem? Otherwise i would try to change the Adapter.



Hi @Rene_Thiele Have you tried re-installing the device driver from Anker’s website for Windows 10?

Yes but without any result, but the driver from the Realtek Site is the newer one. I tried both but both drivers are only with USB 2.0.