Unsecure website!

I got a message from my browser that the connection is not sure anymore.
You might renew the certificat asap


Just got the same message Franz. It says the certificate expired 1 day ago.
Safari keeps making me jump through hoops to get to the community.


There are updates being done in the background over Feb-March so this might be one of the few things we might see happening…

@AnkerOfficial @AnkerTechnical can you advise on when this will be resolved?

1 Like

Beat me to it!

Just a simple expiration of the certificate, no actual security issues to worry about though.

@AnkerOfficial @AnkerTechnical - We’re assuming you’re aware of this?

Could be repaired as usual.
I posted this to calm others.
No panic.
There is NOTHING wrong!
Nothing will be stolen…

1 Like

Yes, sure. Nobody intends to build a wall …

Thanks for posting @fhassm, I was worried that it was just me. Feeling better now. Hope they resolve it sooner. @AnkerTechnical, @AnkerOfficial


i got this this morning also.

Same got the same message

I got this once early this morning, now looks fine. Believe Anker may have fixed the certificate

Its all fine now.
Don’t worry be happy.


Yes I got the same thing. I guess it was no longer forcing https? Idk. My browser on my phone wouldn’t even let me on the site for several hours. (Worst hours of my life :sob::joy::sob::joy:)

I got the same error but issue fixed. Thanks.

1 Like

Glad it worked out fine :slight_smile:

I see it’s working fine for me too! No comment from Anker but seems they fixed it.

Should be ok, so long as you don’t go outside the community.

If you go to anker.com or PU page etc, and then try to come back, it will be hard work.

I haven’t left the community yet, and haven’t had that warning. :exploding_head:

1 Like

I’m glad they took care of it. I didn’t face any issues earlier tho so I must’ve missed it