Unable to Connect my Eufy RoboVac 25C to my Smartphone/Wi-Fi

I just recently bought a RoboVac 25C and I’m still attempting to connect it to my Samsung Android device or even in wi-fi, both of which have no been able to connect properly.

I attempted to restart the RoboVac as the instructions say, but the sensors on top of the RoboVac wouldn’t work whenever I pressed the start/stop button with my fingers. The remote does not work either, even after using a completely new set of batteries.

Have you setup the Robovac 15C the first time OR never been able to set it up.

If you have not been able to set it up earlier, Make sure to have 2.4GHz Wifi available for connecting the Robovac.

Only the below are supported Wi-Fi networks:

  • IEEE 802.11b (Not recommended)
  • IEEE 802.11g
  • IEEE 802.11n (Support only for 2.4GHz)

RoboVac does not support 5GHz networks.

  • Make sure you are within range of your Wi-Fi router.
  • Make sure your Wi-Fi router is switched on.
  • Make sure your smartphone is connected to your Wi-Fi router.
  • If the SSID of your network is hidden, manually search for the hidden network you want to connect RoboVac to.

Make sure the Wi-Fi network name or the password you entered is correct. If it is incorrect, please try again.
2. Check whether there are any Internet connection problems. If the Wi-Fi signal is too weak, reset your Wi-Fi router and try again.
3. If there are too many devices connected to your wireless router at once, disconnect a few devices and try again.
4. Check to see if the side switch on RoboVac is turned on (in the “I” position) and make sure your RoboVac operates normally.
5. If the issue persists, long-press the Auto cleaning on/off button for 10 seconds to reset RoboVac. After you hear one beep and see the Wi-Fi status light start to flash, follow the instructions in the EufyHome app to set up the Wi-Fi connection.

Also please make sure to contact at support@eufylife.com - keep the purchase proof handy

This is from my earlier post

Well, currently I believe my router is a dual-band router, uses both 2.4Ghz and 5Ghz. I’m not the smartest when it comes to this, but on my router is shows that both 2.4Ghz and 5Ghz both have a green light, which I’d assume means they’re both on. Would that mean I’d have to turn off the 5Ghz in order to use the RoboVac?

Apologies, this is the first time I’ve ever purchased a RoboVac.

Don’t need to turn off 5GHz. Just make sure the SSIDs are different for both these bands, and you try to connect to 2.4GHz.

Also there are detailed steps here with screenshots

Do you happen to have any sort of tutorial for how to separate bands?

Which router brand do you have? Usually have different SSID names for 2.4 and 5 Ghz bands.

Should be pretty simple on Netgear and Asus routers

If you tell us the type of the router you are using helping might be easier as @Shenoy
mentioned. The RoboVac can be connected to 2.4Ghz only.

@legomasterman22

On your phone/tablet during the initial setup and connection to Wi-Fi Turn on airplane mode and then turn Wi-Fi back on.

Your phone should then be able to connect to the robovac enabling you to connect your robovac to the Wi-Fi and finish the setup procedure.

It would also help when during setup your phone robovac and router are fairly close to each other.

You shouldn’t need to mess around with your Wi-Fi settings and should only need to know name of the 2.4 band & password. But for future reference.
All of the login info that you need should be printed on the bottom of the router but if it’s not you can Google the model number of your router to get the the login info most likely admin and password (factory default you can change once you’re in there) when you Google the router it will also tell you which IP address to navigate to in your web browser (chrome Firefox Internet explorer) to login and play around with the settings. Personally I name my 2.4 Network whatever I like and then copy the name but with 5G at the end for the 5G band keeping that password the same for both bands.

This doesn’t really apply to you since the robovac won’t connect to the 5G Network anyway but the main difference between 2.4 and 5ghz is that 5G is much faster and able to connect to many more devices simultaneously but the signal is not as robust as 2.4 and will not penetrate through walls as well as 2.4 or travel long distances.

If you have dead Wi-Fi zones in your house it is best to relocate your router into a high place away from electronics large solid metal objects or concrete/stone walls and electrical wiring i.e sockets/electrical panels.

Well, my wifi does not have 2 separate 2.4 GHz or 5 GHz bands, and after almost a full day of research, I’ve decided to just buy a separate 2.4 GHz router to hook it up in the room that my RoboVac will be in. The people that installed this current one took the package and basically everything that included info of the router.

My old router was much easier than this one, so apologies to those attempting to explain the issues that I’ve been attempting to fix. Hopefully installing this minor 2.4GHz router will fix the issue and allow me to expand with these types of products, thank you!

1 Like

Sounds good! Please keep us posted how the setup goes with Robovac once you get the new router

It would help us if you would supply us with some model numbers.

I see that you said the people that installed the router took the box and manual with them but model number should still be printed on the router.

I have never heard of a pure 5G router but I could be totally under informed but it is my feeling that the current routers that you do own is capable of outputting both bands but the 2.4 is turned off which can be changed in the settings of the router by going to the IP address printed on the bottom and using the login info username and password also printed on the bottom.

Well, I’m using a CenturyLink Calix 844G GigaCenter dual band router, I know that for sure, but there’s no sort of paper slip on the bottom of it like my old router had. I’ll look over it again later, but last I checked I couldn’t find anywhere that had any info of the router.

EDIT; I looked up this router throughout the internet just a moment ago, found a lot of info on the router after a bit more digging. Apologies for the constant nagging of this thread.

Looked it up… Shows as dual band router so you should be able to setup Robovac on it

CenturyLink Calix 844G Wireless 2.4 GHZ 5G Dual WiFi Internet Modem GigaCenter

1 Like

Also, out of curiosity does this run offline as well? Like, if my internet went out due to maintenance (cause there’s maintenance that needs to be done next week) will the vacuum still run or is it wi-fi required?

Yes, Robovac 25C can run offline completely, and can be controlled using the remote included or simply pressing the buttons on top of Robovac unit

1 Like

Hmmm, ok ok. Well, I’ll see what I can do cause it hasn’t even been able to vacuum yet.

Charge the Robovac unit fully, once fully chaged, use the remote or buttons - it should work well.

To change settings on the Wi-Fi router navigate to the website-ip address

192.168.0.1
Username_admin
Password_sqw6Fsy6

1 Like

Back to the roots! :joy:

1 Like