Troubleshooting anker 26800 powercore+ Pd

I have 2 anker 26800 power core+. Both worked great for almost 6months.

Now one of the battery packs. The USB c doesn’t charge any devices. Like I’ve said I have 2. So I’ve swapped cords and it doesnt work on broken one. So it’s not cable in my opinion.

I’ve tried to reset circuit or whatever by plugging USBA into USBc. No luck there either.

So I thought it wasn’t connecting at all. But actually on my phone it says.

Charging connected device via USB. Makes it sound like my phone is charging battery pack?

So any suggestions?

@Justin_Richard Sounds like you’ve covered the main troubleshooting steps.

Shoot a email with your purchase date, serial no and troubleshooting steps taken for assistance and/or replacement under your 18 month warranty.

Ok…I feel bad just sent me new cables. Now I got message them back about battery pack lmao :sweat_smile::sweat_smile::confused:

If you are under warranty you should make a video
Showing the issues and send it to the support.
I see you made all steps for troubleshooting.

Sounds like the same issue I had with it. I had to contact Anker and have it R.M.A’d.