Synology Surveillance Station and eufycam

So, I’ve tried loads of different RTSP paths, but none of them work. Camera test failed every time. Anyone got this working? What is the correct format for the path please? The hint on the Add Camera Wizard screen could be clearer (see screenshot).


I am having the same issue. I would love to know as well if anyone has had any luck getting this to work.

1 Like

I have the same problem with my QNAP NAS server and QNAP surveillance station.
Rtsp doens’t work with VLC player too.

When I ad the camera in the QNAP servaillance station I have the message: can’t connect to ‘live.sdp’

I have a QNAP and get the same issue. no RTSP on surveillance station nor VLC.

I am unable to do this as well, which is frustrating because during development the team said they had successfully gotten this to work with Synology specifically. They’ve given no update since.

Anker - please provide instructions!


can anyone provide a proper RTSP URL please?

same here - tested all combinations of rtsp-links
nothing works :frowning:

I’m interested if any of you have success setting up your NAS with the latest release, which we got notified about today, 03Jan19?

If you do, please post your results/efforts here. This is obviously something that plenty of us EufyCam users want to do.

I tried with a Synology NAS, but it is not working for me (running lates APP Update on IOS) and copied the rtsp Link like described in the App

I got this working on QNAP surveillance station - I had to go back in and set the WAN ports again after setting the cameras. It didn’t start working till homebase went to

Below are my camera settings, I have 2 cameras, 2nd one is identical setup except the http URL says “/live1”

Just to note that the “test” does not work as the RTSP stream seems to only be generated when the events are triggered (e.g. camera detects motion and sends video to homebase). I note I have some recordings but I have not played around with it much to be honest.

You need to edit the link as per my below screenshot :slight_smile:

@Springfield I would guess based on what is written on this screenshot you need to enter (in the last box) this:

You need to change the IP to whatever your app gives you, above is an example. 554 is RTSP port.

For additional cameras the “live0” bit changes, increment the digit.

In my experience the live test does not work as the cameras only send data when triggered, just add it and see :slight_smile:

Same issue for me. Doesnt work with Synology NAS.

@bushbrother Thanks for the advice. No joy though :frowning:

Clicked ‘Next’ and got this:

Hi, I tried with my Synology NAS, but it is failed all RTSP links copied on my iOS app (after last upgrade): not work.

Apparently a new update will fix this. My cameras are on 1.7.1 and HB on See discussion on here:

1 Like

@Springfield Seems the Synology requires it to be streaming to add, where as QNAP does not need to test the stream to add. Looking on the help page it does say:

“Watch live streaming on the App, so that it wakes up and push stream to NAS.
Then it will pass the Test Connection. If it fails, please trigger the camera again and retry.”

Try doing that using the settings I suggested.

That’s what I did, thanks. No joy.

i can’t add them too…
i hope they can fix the issue (: would be nice to save the eufy cam data on my synology nas

This doesn’t work for me either (Synology NAS).
Looks like there’s a bug!