Ssd reader not showing up in Windows 10 explorer window after Windows update

Hi, I’ve had a couple of Anker ssd readers for a couple of years now. I generally only use them when I do a clean install of Windows (like today) on a fresh ssd. I use the reader to access stuff on the old ssd, Outlook files and documents etc. This time, though, after installing the latest Windows version, I can’t get the old ssd to show up in Windows explorer. It’s recognized in Control Panel’s list of storage units, so it’s obviously registered somehow. Does anyone know if there’s a fix for this? Any suggestions much appreciated!

Chris Saunders

I avoid Windows if at all possible due to a history of poor quality, but I still am familiar with the generic problem you describe, and what I would do it check that the filesystem is supported. The sort of example is Windows latest version does not bundle an older filesystem support, like FAT, exFAT or older NTFS support. Check for filesystem support as part of eliminating causes.

Obvious other methods with Windows is to uninstall the device and replug in to kick it.

Update Windows and let it drag in patches then try again (uninstall, replug).

Typed on a Chromebook.

As it is detected by the system, have you checked disk management, in case a drive letter just needs assigning (conflict due to a previous mapping)?

Thanks nigelhealy and ndalby for suggestions. I’ll have a look at both a bit later. I’ve tried removing and replacing them without success. I tried checking disk management but it couldn’t start something called a virtual something or other, so I didn’t get far with that. I’ll try them on another computer - though that’s been updated too, so it might not work.

I’ll let you know. Not surprising people get fed up with updates :slight_smile:

Ahh, remembering yes.

Windows changed drive mapping in newer OS as the drive letter is built into the filesystem so if you moved the SSD from one device to another then you’d get a conflict. You could well be right!

Of course Linux doesn’t have drive letters.

No, doesn’t look like anything’s going to work. I thought I could use the old ssds to mine data, but it looks as if I was mistaken. I can’t get the reader to be recognized on my other home computer either. I think I probably made a mistake when I said that the old ssd was recognized in device manager. It was an ssd still inside the computer.

One thing which did surprise me is that in my downloads folder, there was an update to the reader: 68UP25EN-BRSU FW. I’ve installed it, and it turns out it’s something called MPTool, which I haven’t a clue what does or how to use it. Any of you know perhaps?

Anyway, thanks for your help so far!


MPTool is a firmware flash utility. So you don’t get any detection sounds in Windows or refresh’s in ‘device manager’ when the reader is attached? Sounds like a dead reader if neither of those occur…

Well, the indicator led on the reader itself lights up. I’ve got a different harddisk reader, and device manager shows that it registers ordinary harddrives (though I haven’t heard any beeps), but not my old ssds for some reason. I think I’ll try disconnecting one of the new, empty ssds in the computer, and connecting the old ssd. That might help.

Well, I did as said and connected the old ssd to the computer. It worked, and although there wasn’t much on it, there were ‘my documents’ and downloads, and both are important. I’ve got another old ssd, but I’m beginning to wonder if it might not have survived being removed from the computer.

So the older SSD is detected when hardwired into the computer using a SATA cable but not on your Anker reader (do you have a link to the reader model) which is lit when connected? Still thinking it has something to do with drive lettring / management. Can you post your hard drive setup, namely what’s on the inside of your PC and their drive letters and what you are connecting is the reader (USB)?