SoundCore Spirit Connection issues and impossible to turn off

like already told in the topic’s name, I’ve got some problems with my SoundCore Spirit In-Ears I recently bought via Amazon (~14 days ago).
Since yesterday (still worked in the morning. In the afternoon they were empty and I thought I just had to charge them) they dont work anymore.


  • When I connect them to my Phone they connect to it for like 5 to 10 seconds before disconnecting. My phone is showing the “connected icon” for another 10 to 20 seconds until it disappears there as well.
    During this small window of connected time I get no sound. Doesnt matter if I turn the Sound up at my phone or at the In Ears.

  • Its impossible to turn them off. Like in the manual told I press the middle button for like 3-5 seconds until the LED is turning red. After this the LED turns off for a short time just to start flashing blue again without any reason. (the blue flashing when you connect it to a new device)

What did I do to fix the problem?

  • restarted Phone
  • deleted bluetooth profile on phone and In-Ears (pressed vol. up and the middle button for a few seconds)
  • recharged them to 100% (I dont know how this should help here but I read about this and well… Just gave it a try.)

My Phone: One Plus 5 with Android 9 (no patches or software updates since yesterday)

In advance,
thank you very much for your help.


Does your phone do Bluetooth 5?

As the earphones are bt 5, and if you do t have that but say BT 4.2 they’re not compatible.

Just a thought.

I am having the same issue. They were working a few days ago and now all of sudden they wont connect to my laptop. i’ve tried disconnecting the ear buds from my laptop and reconnecting but no luck.