Soundcore Q20 NCA message is looping!


Have used these headphones for almost a year and they have been excellent.

Suddenly, after I turn on the Q20, (and don’t even touch the NCA button) the voice over that announces the Noise Cancellation keeps repeating. First she says “Off”, then waits a bit and says “Noise Cancelling”, then waits about 20 seconds and says “Off”. And this keeps repeating! It ruins my music listening.

I tried the factory reset several times, but it did not help.

Is there any way to end this crazy looping?

Sounds like the button is stuck.

Turn off the headphones.

Use cotton tip dipped in isopropyl alcohol and clean around the edge of the button, press it a few times and keep cleaning. Dampening with the alcohol then pressing in will push the alcohol (solvent) into the debris inside and pull the debris out, so repeated cleaning with clean tip+solvent will then dissolve+lift+remove debris away.

Only use isopropyl alcohol, anything else will bleach the plastic.

Let it then evaporate for a while, say in the sun by a window, before turning on buds.


Professor you have the right name, because this worked!

I don’t believe it was dirt exactly–I keep my electronics almost pristine, but I suspect I pressed the buttons overly hard the other day when I was in a hurry to put away the phones.

I did exactly as you suggested, besides prying gently around the button with the edge of a clean Exacto knife.

Worked a charm. Many thanks!!


Maybe if you can, and if it still allows, can you mark this as solved by @professor post?

I think it can be done on your initial message by selecting the 3 dots, lower right.

1 Like

Thanks. I’m just extremely old and my kids had sticky fingers with the TV remote. Memories.


Don’t agree. Pressing hard just made it stick, you still had goo inside to keep it stuck. The human skin is shedding grease and all buttons get it from use and so all buttons suffer it eventually.

No don’t do that, it causes a slight scratch, dent, recess, through which grease can then work in faster. Just wipe with the alcohol press, wipe, press, repeat til it naturally pops up then leave to dry.

1 Like


1 Like

Glad to. But how exactly? I don’t anything to click that indicates “solved” status. Even if I go into Edit mode.
What to do?

I’ll see if I can figure it out… I’ve never done it before either :slight_smile:

Thinking this post may cover it…

Although in looking at one of my themes, I didn’t see the option. Mind you I’m on mobile. Might be different on desktop / laptop.

1 Like

I must be blind. All the posts aside from my original, when looked at in Safari on Mac, show a check-mark box, dimmed. When I click any of those, they turn green.
Now does everyone have this option, or only the OP? Don’t know.
I will look at some other threads on this forum to see.

I think that is how it works. I just looked at another thread, and the Professor posted a response there. I could “heart” his post, but there was no “checkmark” icon. So yes, I reckon only the OP can mark “Solved.” Which is logical.


The OP can say solved at their discretion based on who helped. You can select multiple if its a team effort but only the last one you tick is the solution at the top of the OP so pick the best fit answer last. Lower right corner the “solution” you can tick it.


1 Like