Soundcore Mini firmware fail

Hi guys so i bought a soundcore mini which had annoying latency issues with ipad pro or iphone xs resulting in a second or so lag when trying to watch youtube or netflix

Read about updating the device firmware to supposedly help fix it which i did with this firmware - A3107_Soundcore Mini 2 V6.25-20180130.fw the software claimed the update went fine yet the device will now not turn on, it just flashes quickly and does nothing…

Any suggestions? thanks in advance

wait this is mine -

perhaps i have flashed it with the wrong firmware lol :confused: anyone know where i can get the firmware for this one?

Check the link here:

cheers but thats the wrong firmware i used to flash it with for the mini 2 :frowning: this is just the mini, it is the mini firmware i need now to fix it

Wow I don’t even see Mini or Mini 2 anywhere on site. In your case you might just have to email Anker Support. They should be able to help you out

1 Like

Hopefully they can send me a link to download the firmware, cant seem to locate it online anywhere :frowning:

Wow I never we had firmware upgrades!

I just tried the Mini 2 upgrade on my Mini 2, and I double-checked I used correct file and it said firmware upgrade incompatible with my device :frowning:

Mine is now bricked and PC wont recognise it, I tried the other firmware on site too, ugh who releases software with no checks, i never got no incompatible error or warning :frowning:

I can’t help you but I am puzzled, in my case I used the correct firmware for my device and checked and said incompatible and yet you were allowed to use the wrong firmware. Why did it fail (when should have worked) for me and it worked (when it should not have worked) for you?

its wrong on all levels, I should not have been able to install both “wrong” versions to the device but you should have been able to install the correct one to yours, a bit of a mystery…

1 Like

Seems weird how you were able to complete an update when the hardware revisions are different…have you tried resetting the speaker by holding the mode button for 3-5 seconds?

Failing that you will need to reach out to with your issue and troubleshooting steps taken.

I agree and yes nothing does much now :frowning:

I have received that error code before when I was absolutely sure I was using the correct firmware. I just downloaded the firmware again and the update worked first try…

Dear @RobFallen ; we are so sorry to hear you are having a problem with SoundCore mini speaker, we regret that there’s no firmware designed for SoundCore mini speaker at present,so we would not suggest you to upgrade the speaker via firmware.

Regarding the issue you mentioned, please try following tips to see if that help:

  • Confirm the speaker is fully charged
  • Reset the speaker by pressing and holding the Mode button for 3-5 seconds
  • Try the speaker with another device;try another app or audio source
  • Try using an aux audio cable to see if that’s better

If the issue persists, please contact us via for further assistance.

Sorry to say this is the issue with Apple products in general, there have been many discussions and tech talks about how Apple products always kag playing YouTube or Netflix. It’s more to do with apples ecosystem and how they make things work or don’t in this case. Search in YouTube for Apple products lagging or slowing playing YouTube videos and same for Netflix and you will see it’s an jnherent problem across the board.

Now some apple products just work and others lag, in the end blame Apple

Guys please i need firmware for Soundcore mini 3 firmware file. My soundcore mini 3 stop powering up but the indicator for charing comes on whenever i connect it to a charger. I recently disconnected the battery and reconnect it, it worked for a day and stopped sounding, even though it would show that its connected the sound won’t come out, it appears connected on the phone and the blue led light confirms it. It doesn’t give the start up sound when its been powered up. So i am thinking of reloading the firmware.

Have you checked the battery with a battery tester?
You say, you disconnected the battery so it seems you have opened tzhe speaker.
Maybe the battery s defective.
Same happened to me with a flare mini.

The Battery is fine, as it was low when i opened it and it charged well and the speaker worked for some time. When i connect to the device it connects, but the speaker is not sounding. Every other thing works fine except that what is playing is not coming out.

Ok, it worked first for about one day with sound after opening and assembling
Now after one day there is no more sound BUT the battery is fully charged.
Because the disconnection and connection of the battery is quasi a hard reset,
there is no need to do such one.
Have you tried to connect the speaker to another device?
Has the speaker an AUX-output?
I dont have, so I dont know.