Soundcore Life Q20 Wireless Headphones Stopped Working.....Again.

A few weeks ago, I got a pair of Soundcore Life Q20 headphones, and after charging them out of the box, they worked perfectly for a few hours. I tried turning them on the next morning and they wouldn’t turn on. Every time I plugged them in to charge, the red light would go on and then a few minutes later would go off. But no matter how long I charged them, I couldn’t get them to turn on again.

I had to send the headphones back and was just shipped a new pair. And now…

Exactly the same thing happened. I was able to use them over the weekend, but after charging them again I’m back at the same problem: I plug them in using the supplied Micro USB cable and using a wall charger I use with several other Anker devices (charger, wireless speaker). The red light goes on, and a while later goes off. But when I try to power on the headphones, nothing happens. While charging, when I hit the power button, the red light goes on.

So to sum it up:

      1. Twice I received a pair of soundcore Life Q20 wireless headphones, and in both cases they worked after the initial charge, and then stopped working the next day.
    • In both cases, I used the supplied MicroUSB cable and attached to a wall charger that I’ve used for several other Anker products that have no issue.
  1. *In both cases, it was suggested I try a different MicroUSB cable and a different wall charger. In both cases, I tried that and it didn’t make a difference. And I’ve made sure to verify that those chargers and cables work with other devices.

This is driving me nuts, as I really like the headphones and actually bought a pair for everyone on my team. It seems like either:

  1. I just had bad luck and got two pairs of headphones that malfunctioned (seems odd)
  2. I’m the problem. Totally possible, but I’ve done all I can to isolate the variables.

I really want them to work, but I also don’t want to keep sending them back over and over.

Any ideas would be most welcome and helpful!!

1 Like

Try charging using a laptop or powerbank. See if doing any of that helps. I see you tried with other cables and chargers so that’s not a problem for sure. If it still doesn’t charge properly, sadly you’ll have to contact Soundcore ( again and get it switched out for new pair.

Edit: Didn’t mean to have a hyperlink or something there. Not sure why it’s blue

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Thank you for trying some troubleshooting already.

Don’t worry, please don’t hesitate to contact us at by detailing your order number and the problem you come across. We will reply you within 24 hours.

Got mine yesterday. when i started charging via charger or laptop it shows me red light which disappears in 2-3 mins. It is plugged in for 8 hours but it’s not charging. My pins are just fine and tried all the possible things mentioned here. By any chance can you please help me? This is so sad to see most of this life q20 serious has this issue. I used my saved money on these headphones just for a one day of use.

The information you’re sharing is very familiar to me (exactly!). I’ve been sent 3 sets now and it happened to each set. I had hoped it was just a bad first pair, then thought I had incredibly bad luck when the second pair stopped after the initial charge. When the 3rd pair stopped working, Anker lost my trust (despite their willingness to keep replacing the headphones — it’s a hassle to keep sending back for a new set for ~24 hour’s worth of music).