Soundcore Life Q20 static/white noise with aux cable connected

Recently bought a Q20 but discovered it makes a lot of white noise, even humming, when using the aux audio jack cable. When I switch to bluetooth, the white noise disappears.

The problem is that I need to use the aux cable to connect my Q20 to my computer when on Teams: when I use BlueTooth, I cannot hear all the sound tracks coming from my computer. For instance, when I am on Teams and I need to watch a video at the same time, I can’t hear the sound from the video, only the sound coming from Teams. When I plug the aux cable, I can hear both the sound from Teams and from my video. But then, there is a lot of static/white noise.

Maybe there is a fix to make it possible to hear all tracks through BlueTooth? That would solve part of the issue.

The remaining issue is to fix the static/white noise when using the aux cable. I guess this is not normal functioning, right?

Teams and other video calling software use Hands-free AG as audio output and videos normally output as stereo. So I recommend you try to get your audio output to Hands-free AG and see if that solves your issue. I know that because I’ve been working on team assignments through MS Teams (thanks to the pandemic).

You just have to click the volume controller and select the output when Life Q20 is connected

image

Thanks a lot, this solved one issue!!
I can now hear multiple audio tracks when using the Q20 with Bluetooth. Wonderful.

Yet, the other problems persists when using the Q20 with the aux cable: there is a lot of static/white noise (especially when someone is talking on Teams) (Problem 1)

In addition, nobody can hear me when I talk: it looks like plugging the aux cable of the Q20 switches off the computer microphone. (Problem 2)

Any idea with either of these issues?

1 Like

Idk how you can solve problem 1 tbh. I have Life 2 (predecessor to Life Q20) and haven’t had issue of white noise with AUX ever.

But for problem 2, I know that AUX cable doesn’t have an in-line mic so it can’t use the headphone’s mic and you have to rely on the laptop mic. If it switches off the computer mic then it’s some setting on your computer that you have to tweak

Thanks for the tip, but I couldn’t see any setting on my computer to change. I looked into the audio panel settings, the computer microphone is selected as input, but still it work when the AUX cable is plugged in. I don’t understand.

Now the real (bothering) issue is the white noise when using the AUX cable…

Have you tried a different cable? It doesn’t take long for most cables to develop a near break. Maybe try putting it out to a speaker as a sanity check. They’ll likely be tuned differently so you might need to fiddle w eq. Also, can you just pull the noise out w equalizer? I’d look in the .5-4kHz range.

What OS are you on and software are you using for sound/ audio control. Prolly looking for an option to specify line in as headphones rather than headset… but without knowing thwe environment I couldn’t begin to tell you where to look. Unless you get a pop up dialog when you plug the 3.5 into computer, cause that’s prolly one place to do so

Thanks for the tip. In the meantime I bought another jack-cable. I just received and tested it: same problem. The Q20 keeps making strong white noise when connected with the (new) cable. It does this both on a Windows10 laptop and on a MacBook pro. Drives me crazy. So, in any case, nothing’s wrong with the cable itself. I don’t know what else to do.

I’ve noticed the same issue with my new Q20s. Harder to notice at higher volumes but becomes incredible obvious at low volumes. Especially as songs are fading out. Could this be a problem with my individual unit, or is this pervasive across all Q20s?

I have the exact some issue with my Q20. From my experience, the problem only occurs whenever you have noise cancelling on with the aux cable connected. I’m not sure if that can help people fix the overall problem, but if you’re tired of hearing the white noise, I’d recommend trying that.


I had recently purchased life q20 and even I have faced white noise issue on laptop when connected with aux cable but it was working fine on mobile. To make it work on laptop, I had to go Sound Settings in Control panel on windows 10 and select the headphones displayed, go to properties → Advanced menu and uncheck Enable audio enhancements if it is enabled. Voila, after disabling this option, headphones were working fine with aux cable.