Soundcore Life Q20 not charging (red light doesn't turn on)

Hi everyone,
I’m using Soundcore Life Q20 for 5 months and it suddenly started not charging yesterday. Red light that shows device is charging doesn’t turn on when I plugin the usb cable. I tried couple of USB cables and chargers to charge the device to make sure this issue is not related with cable or charger and result is same. I’ve left the device on charge although red light is off but it didn’t work as well.

Device can be turned on but it automatically turns off after 3-4 seconds saying after saying “Battery low”.

Is there anyone who faced with this problem and help me to solve this problem?



When you say couple of chargers, are they all 5V simple chargers? Some chargers won’t work.

It does appear a failed unit, but try doing a reset.

Yes, all of them are 5V chargers and these chargers were the ones that I used to charge the device all the time.

Since charging doesn’t work, I’m not able to restart the device as well. As indicated in user manuel; after plugin the device to charger, I pressed the turn up volume button for 5 seconds but it didn’t work.

Do I need to any extra work for restarting it?


I’ve had no luck with 3 sets of Q20s. They work with the charge from the factory, but when it’s gone, they no longer charge for me. Many chargers, many cables (all work for other devices); just a solid red light — no blinking; no charging. Resets don’t help either.

Almost same story in here: 6 months after purchased my headphones. Suddenly I cannot charge the phone. The red led for charging does not turn on. Tried several chargers.

Also, It still has like 10% of the charge (as it shows when I see from the bluetooth connections of the mac book), but I am not able to reset by pressing the +volume or +volume and power buttons for 5 seconds.

Have you any tip for this?