Soundcore Life P2 - No RIGHT audio but pause/play works

I have tried the reset & still only the left earbud works. However, despite having no sound on the right side, clicking still works to pause and play audio.

Any recommendations?

By the way, prior to the right side stopping to work, I heard a cracking sound every few weeks or so (for a brief second).

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Please try the following steps to see if it helps at all.

  • Forget the pairing record on your device and turn off the Bluetooth on your device
  • Place the earbuds into the charging case and make sure they are being charged.
  • Press and hold the button on both earbuds for 3 seconds. The LED indicators will flash red 3 times and then turn white.
  • Close the charging case, wait for several minutes and then take them out of the charging case, the white light on one side will flash quickly, which means it enters pairing mode
  • Enable the Bluetooth on your phone. You can find the device name "Soundcore Life P2 " or “Soundcore Life P2-L” on the Bluetooth list.
  • Please click "Soundcore Life P2 " or “Soundcore Life P2-L” for pairing, the white light will flash slowly, which means it paired successfully.
  • Then there will pop out a screen with “Bluetooth Pairing Request”, just click “Pair” (this step is very important)

Please note, due to the chips platform’s compatibility, in the bluetooth pairing list the Soundcore Life P2 is displayed as “connected”, and the Soundcore Life P2-L is displayed as “not connected”. In fact, the earbuds are normally TWS paired to work.

If the issue still persists, don’t worry, please don’t hesitate to contact us at service@soundcore.com by detailing your order number and the problem you come across. We will reply you within 24 hours.

I’m running into this same problem for the third time haha.
I got a pair of life dot 2 earbuds on Amazon, and right out of the box the right earbud didn’t work, could pause and play, but no sound. Long press reset/unpair didn’t help. Occasionally if you touched it or wiggled it the sound would come on momentarily.

I got a refund/replacement…but now several months later i ran into the same issue. i was hoping there was some solution or fix, but seems like it’s just a bizarre hardware defect