Soundcore Life 2 not powering on

Hi all,
Want to share my problem with Anker Soundcore Life 2.
Got it two weeks ago. Was using it about 30 min a day and everything was great since yesterday. Yesterday I’ve tried to power it on but nothing happened. I’ve thought it needs to be charged and left it on charge for a half of a day. After that I’ve tried again but still no reaction for power button. I was surprised but ANC turns on and of fine. Putting to charge again shows red light for few minutes and blue lights come up after that. Even with red light my charger shows no consumption. I’ve tried resetting by pressing Vol+ and Power. Red and blue lights blink for two times each and after that still no reaction for power button. One time after pressing and holding different combinations I’ve powered it on. Music was played but I was not able to power off. It made me feel that it is button problem but not 100% sure. Connecting charger powered off headphones and cannot power it on again tho.
I’ve sent request to support. They’ve asked for details and have not responded yet.
Maybe any advises here?
Thanks in advance

1 Like

That definitely sounds like a button problem. If ANC is turning on and it shows it’s fully charged, there’s definitely no reason for it to be a battery issue. I own one and can be 100% sure it’s button that’s messed up. Get an exchange for this and let Soundcore know all the details including the answer(s) you get here (or just have the link to this thread for their referrence)

The only thing that makes me think it’s not just button problem is that when it charging and holding Power + Vol+ makes it blink red/blue twice. This means it reacts for pressing Power button. So it’s not just button broken.
Also, I’ve found the other thin. I can power it up, but only with this steps (found it for BT speakers)
1.Hold all 5 buttons for 30 sec.
2. After that it starts normally but Power button still doesn’t make anything. If I put a charger plug in headphones it stop working and can’t start with power button again.
This makes me think like it’s a software or firmware issue. But I’m not sure still. Probably there is another option to reset headphones except holding Pwr&Vol+. Will keep trying for now.

Huh that’s super weird. But I would still get it exchanged unless Soundcore can help you in some way without having it exchanged.

That definitely not the way I can use it further :slight_smile:
Waiting for solution from support

1 Like

I’ve tried to disassemble it. Disconnecting battery and shorting power pins on board made headphones work normally. But in a week issue returned. Disconnecting battery and holding all buttons not helps anymore. Looks like I’ve got a wired headphones instead of bluetooth now :frowning:

Considering you went through all that, you just voided the warranty and Soundcore won’t be able to help you anymore. What did Soundcore say in the reply?

They’ve made a refund but I would prefer replacement :frowning: Since I’ve bought it with big discount new one q20 is twice more expensive than life2 was. Cause of that I’ve decided to try to figure out why it doesn’t work. By the way it is very easy to open it.

Hmm that seems odd too. What country are you from? Here in US, they offer exchange as long as you buy from AnkerDirect (check the sold by on Amazon or Ebay listing). Also in US, Life Q20 are on sale for $40 (not sure if they changed that today or not)

I’ve bought it from AliExpress. Replacement was not available cause this model is discontinued. And now I’m pretty afraid to buy q20 since such a problem with life 2.

Hello, I’ve bought the exact same model of these and am having the same issue, am wondering if you managed to find a fix? thank you

Unfortunately no. I’ve liked these headpones a lot but without bluetooth it was worthless for me so I got rid of it. You better to contact support, probably they could help you.

I tried to, they gave me a ticket number but nothing further, am still waiting for a solution. I really loved these headphones too and I think they’re worth more than the Q10, I will just wait and see whatever they offer me to do, and thank you replying back.

Tell me please if they can help with getting it back to life. You could also try my method with disconnecting battery and shorting power pins on the board. To disassemble it you need to unplug leather pad (it is separate part on clips) and you will see screws.

Got the same problem :face_with_raised_eyebrow:

Wait, couldn’t it just be reacting to the Vol+ button? What happens if you push and hold just the Vol+ ? If it does the same, it still might be a faulty power button.

Same thing here. The Power/Bluetooth button does NOT light up, but the NC button does.

Plugging the 1/8" cable to listen to an analog audio source works.

I believe the Power button is not so much a power button, but more a Bluetooth button. If it doesn’t light up, you don’t have Bluetooth, and you cannot connect through the air.

I have the same issue with my Soundcore Life 2 headphones… I’ve already had it replaced twice. This third pair had the problem happen before being recharged a single time.
Ordered in April, first dead in June, 1st replacement dead in August, 2nd replacement dead in October.
Not that this makes any difference, but my Q20 which I got in June is still working properly.

Power button is a power button and not a bluetooth button. If it’s powered on, bluetooth pairing process starts. If it is turned off, you can only listen using AUX cable. It’s weird how you guys are having this problem especially since @Robert_Young3 is already on his third pair. The only thing you all can really do is contact Soundcore at and explain this issue. I know how frustrating it is for sure since I own a pair as well and I would lose my mind if something like this happened

Well, the NC functionality works independent of whether the power button is on or not. So the power button is not a true power switch…it just engages the bluetooth to turn on. In my case, the button does not light up and is not functioning.

Also, it’s not weird because we are having the problem. It’s weird that the new product we bought is not working for us. Having said that, I am returning mine to Anker by way of a free NewEgg return label.

These under $50 wireless NC headphones are abundant and produced by a slew of manufacturers. If one brand fails initially, I would not go back to it a second time.