Soundcore Liberty Neo not connecting

Ive had my earbuds for over a year now and theyve been great, but they arent connecting for some reason. Ive tried resetting them all types of ways but nothing is working. Whenever i put them in the charging case, the right bud blinks red then goes white (charging indicator). Any ideas what to do to get them to connect?

Did you pair them with another device, or only the one?

If you did, perhaps they are paired with the other device?

Is the case taking charge? If you have a power bank you can test with, once the powerbank leds go out, the case would be full up.

The other consul I have would be to check over at the soundcore community, use search to see if somebody else has similar experience.

Perhaps the buds aren’t taking charge, did you clean contacts and check to see if the charging pins in the case are sticky?

1 Like

The powerbank idea requires trickle charge mode.

The prognosis isn’t good, you’ve done what we’d normally suggest so the thrust will be to double check everything “2nd pair of eyes”.

Buds a year old are unlikely, but possible, to have died.

  • Cable failure. Try different charging cable, find one you know works good (charges properly something else). Leave it in for many hours.
  • Charger failure. Same as above, try different charger, one known to work, with a cable known to work. Ports may get clogged so be sure what is plugging into the Neo case is verified to be charging fast something else (e.g. phone).
  • fuse in socket, plug something which is proven to charge (e.g. phone) into a proven to work cable in proven to work charger into wall socket and show it works, sometimes the socket is dead due to fuse.
  • the port. Check the case port for debris, often small items carried in pockets, like cases, pick up lint and every time you push cable in, pushes the lint deep into port and so a bright light and magnifying glass on the port look for and remove debris.
  • Lights aren’t working on case. Leave a proven to work cable from a proven to work charger in a verified clean case port, in the case overnight
  • debris on contacts (this one happens often). Over time grease and debris on the buds themselves from being next to ears and touched by hands, stop the charging process. Using isoproply alcohol and swab / quetip, clean the buds pins and the case pins, then leave to dry. If particularly greasy may need multiple cleans. This is a good example of why “it used to work and doesn’t now” can start after months.
  • device failure. Delete all pairing on everything ever paired.
  • Turn off bluetooth on everything ever paired.
  • reboot everything, phone etc.
  • Reset the buds. Are you sure you’re doing it correctly?
  • Try everything now.
  • Pair with one device. See if fixed.
1 Like

I at least hope we get to hear back what was tried, and if it met with success :thinking:

1 Like

Indeed, the more samples of fixes the more we can separate causal from coincidence.

My wife’s printer has stopped working so I’m doing the same thing, reset everything, wiggle everything, to me it’s all obvious stuff but apparently “you know about such things”.

1 Like

Im still not sure what the issue was but the the morning after I posted the question they connected just fine after being in the charging case overnight. The right one still blinks red once as it goes into the charging case (which I dont think is normal, never noticed it before anyhow), but they work fine although the casing fell off the right one, I just glued it back on lol. Thanks for all the wonderful suggestions even though they weren’t needed in the end.


Appreciate you letting us know they are working as intended.

Hopefully for long time :wink:

Wonder why it blinks red, but glad you got it working

By coincidence a possible fix is here, different or emphasised reset instructions.

1 Like

Nice, hopefully it’s helpful to others. I’m lucky I’ve never had this issue with my earbuds