Soundcore Liberty Air stops charging a few minutes inside the case

Hi everybody,
I have this unit (Anker Liberty Air) from yesterday, and I notice that with the charging case fully charged, put the buds inside does not charge the them. If I keep the lid of the case open, I can see the buds are charging (both LEDs on the buds are steadily lit) for a minute, then both LEDs are turned off. If I continue to keep the lid open and take out the buds, then put inside the case again, the buds won’t charge anymore (no LEDs lit).
I sent Soundcore CS an email about this, but since I had it shipped quite a long way, I would love for any software solution, not to shipping back and forth that would take a lot of time.

1 Like

Are you sure the earbuds themselves are not already fully charged? Because mine does this when they are already charged

1 Like

Thank for your reply. When I connect the buds with my iphone and another android table, the battery showing only abou 30-40% charged (even though I leave them in the case for the whole night). So I don’t thing they are fully charged

1 Like
1 Like

Hmm, clean the charge ports on the earbuds and then insert them into the case and make sure to press downj on them to esure good connection

1 Like

Well I purchased this yesterday and they are all new and clean so I don’t think the connector would be the problem. Also when the LEDs on the buds turn off, I tried to push them around, but nothing happened

1 Like

After the reset I’d leave the buds and case to charge until the lights go out.

1 Like

Use the buds till empty then recharge. It may be possible that the battery in has not done 1st charge to form SEI layer. If it don’t improve then contact customer support.

So now if I connect the case to the charger and put the buds inside the case, both of them are charge until full. But if I use the case alone, it will only charge the buds for a minute. I have used the buds until they are out of juice, and recharge them till full, but the same problem still persist. So I guess I’ll return it. Thank you guys for all the help!


There’s one more thing that you could try to fix the charging case which would be to short out the left charging pins in the case with a paperclip that is bent at the very tip/end

If this doesn’t work for you I’m certain you will have no problem getting a replacement set. This is the first I have heard of this particular problem so I wouldn’t worry about the same thing happening with a replacement set.

I am having this same issue. I put the buds in the case and I see they both have lights on. I check about a minute later and the left light is off. I have tried all replies except charging them while the case is charging, and I don’t want to do the paperclip thing because I don’t want to break it.

1 Like

Your not the only one having this issue mine are new as well don’t buy the dusty contact thing

1 Like

I’ve bought the earphones about a month ago and I’ve got the exact same problem. The case doesn’t fully charge the earphones. After charging them over night, they only last for 1 hour max. Does someone know what to do/ who to contact?

1 Like

I received last week these earbuds , I having the same issue , sometimes the earbuds cannot get to 100% even the case is fully charged and the earbuds in it a whole night , then the battery of the earbuds drain after 30min of playing music.

I’m late to this discussion, and have the Air 2 version, but with the same issue.

same exact problem! just purchased them this week and they will charge for 1 minute and light will go off on case. They can stay plugged in all night and no charge. What a disappointment. Guess I will also return.

I am having exact same issue

I am having exactly the same issue, I purchased them from duty free at the airport and can’t exactly return them, the pods just won’t charge, wether the case is connected or not, or rather, they only go to 30%

I have the same problem, the LED turns off minutes after closing the case even if the buds are not fully charged, can someone provide a solution or a work arround for this issue

You could try to clean the contacts with alcohol.