Soundcore Liberty Air 2 - very bad quality when using microphone via bluetooth on Macbookk

I’m so far pleased with the headphones. They work very well for calling and listening on my iPhone (8 plus) and have no issues whatsoever there.

I do however have problems when connecting via bluetooth on my 2020 Macbook Pro (13"). For listening, the headphones work well but when trying to use the microphone, it’s very bad.

It doesn’t matter what app I use, I’ve tried Google Meet, Slack and Quicktime audio recording. The resulting audio quality is very bad. My voice sounds compressed and it drops out, basically it cannot be used for this purpose. I’ve tried disconnecting all devices from notebook, NVRAM and SMC reset but nothing helped.

If I connect only left earbud via bluetooth then it’s usable (although not so great).
Is this a design flaw? Why my phone works well and my computer does not, they both use fairly new bluetooth technology.

I have this same issue. When connected to any Mackbook or Windows PC, the sound quality isn’t bad, it’s tragic… In addition, the built-in microphone “collects” sounds from the surroundings during a phone call so much, that sometimes people which I talk to can’t hear my voice.
As far as I know, many people have a similar problem and I’m very surprised that none of the people responsible for this product have responded to it yet.

Yes I would like some acknowledgment at least if it is a known problem. I remember using way cheaper microphone headphones many years ago that did the same job better.

I have the same issue, can confirm it happens only when using microphone with PC (MacBook Pro in my case). When I change microphone to macbooks’ internal it changes back to good quality.

For me, this is a no-go since I use my Macbook Pro in clamshell mode (closed lid). That means microphone is obstructed and laptop is usually further away from me. That makes it hard for other people to hear me.

Does anyone know if this problem is limited to Macbooks only, perhaps Windows laptops do not have this problem, it might me combination of hardware / software on given computer.

I’ll check Windows and Ubuntu today, and will let you know :slight_smile:

1 Like

Well results are strange. I just tested it on windows and it seems to work, however when I join some meeting on google meets or sth all other sound sources e.g. youtube video are muted. On mac i can hear meeting badly and other sources of sound (also badly). Will check it on the linux soon.

Yeah that is strange. But maybe the muting behaviour is default? However IDK if you’re aware but if you use left headphone only, it somewhat works on Mac OS.
I’m having a suspicion if this has something to do with Bluetooth profile used in Mac OS. I’ve read something similar hapenning to people with (1st gen?) airpods: Airpods mic sound quality is bad on Mac? - Apple Community

I was doing a screen recording with quicktime the other day and noticed the audio quality of the mic was very bad, like an AM radio. […]

Response:

Explanation
Apple claims that the poor Mono 8kHz quality which affects recording and indeed simultaneously playback on Mac when the AirPod microphones are activated is because the SCO codec then gets employed over the entire Mac audio system. This is supposedly “expected behavior” when trying to use the AirPods and other Bluetooth headsets together with a computer, according to Apple.
The AAC codec is normally used when just listening to playback on the AirPods. It’s just very unfortunate that SCO – low-quality as it may be – upon AirPod microphone activation is not only limited to recording but also displaces AAC and audio playback.
Apple Support claims that Apple is looking at this issue and that improvements might be coming in future firmware updates, but I did not interpret that as a promise, to be honest. But for the time being, I’d say that the benefits of making calls and so forth with AirPods on Macs are quite limited.
Current best practice
Current best practice is to use the Internal Microphone for Recording, and the AirPods for playback when conducting calls. Input and Output devices can be selected in System Settings > Sound or by -clicking the Volume icon in the macOS Menu Bar, and selecting devices there.

So yeah the advice again is to use Macbook’s internal microphone, which IMHO just sucks. I wonder if this issue with Airpods might be related to other BT headphones like Soundcore.

It would be great at least to get an acknowledgment from Anker that this is issue with BT codec of the system.

Wow, quite a research. Kudos for you. I’m also looking forward for Anker view on that. Would be great to have feedback from producer site. Btw, Apple is being Apple, why do I even use this garbage :vvv

1 Like

I don’t have any inside knowledge specifically to the Liberty Air 2, but I also struggled with the microphone quality of my Apple AirPods when trying to pair them to a PC for conference calls. This seems to be an issue with most Bluetooth headphones as I’ve tried various models by JBL, Beats as well as SoundCore.

Unfortunately, it comes down to either buying a new Bluetooth adapter for your computer that uses Hands-Free Profile 1.6 or higher, or using a different microphone separate from your Bluetooth earbuds. I’ve summarized what I’ve found in this article. I hope it helps!
https://technicallywell.com/why-does-the-mic-sound-so-bad-when-connecting-my-airpods-bluetooth-headphones-to-my-pc/

2 Likes