Soundcore app not connect to soundcore liberty air 2


I am using the soundcore liberty air 2.

both earbuds are connected to my galaxy note 10 and I can hear sound from both of them, but I can’t connect them both to the soundscore app, i can only connect one earbud at a time to the soundcore app.

I want to connect the earbuds to the app to update the FW and change EQ…

Please check the attached photos for better understanding.

Waiting for your reply.

1 Like

Have you tried completing a reset of the earbuds including a fresh pairing with your phone?


its work!!
many thanks man!

You know I believe your suggestion will work. I know several others people having this issue and it did for them as well. It is just hitting me as funny that this reminds me of computer techs asking people to restart their computers.

No worries, glad your working again :slightly_smiling_face:

Works 9/10, though I often get the same funny looks at work when I suggest to users have you tried a restart :laughing:

Lol I do too. I work for a US state testing and developing software for Federal mandates to a system to document foster care and cps activity . Well some hires are more social worker people than technology savvy. We have a web portal and it aggravates me (also makes me laugh) when the site gets a data port error and I am hearing the help desk asking have they cleared their browser or are they in compatibility mode. Lol.

Wow I’m glad it worked for you. I’ve tried that at least 10 times and they still won’t connect. For more on this read my post about buyers beware. Lol

This reminds of old saying, Rebooting your Computer fixes lots of problems or something I forgot the saying. Please correct me if you don’t mind.

It’s funny: just last week I had an issue on my phone where Siri wouldn’t connect over cellular, so I spent several days troubleshooting it (I thought for sure that my carrier was blocking Siri’s ports) when a simple reboot fixed it immediately. :sweat_smile:

hey, im experiencing this too. I already tried to restart it multiple times, and repaired them too.
But soundcore app couldn’t detect them at all, not even one of them. Yet, while doing so im listening to spotify just fine. What am i missing here?

hey, can you share the link to your post about this?
I might experience your trouble unfortunately.

1 Like

I’ve tried to reset and restart and still can’t connect on the app