SoundBuds Sport wont turn on

Hi everyone!

I recently purchased a pair of soundsbuds from amazon and they worked really well for a few days but now they wont turn on. I’ve charged (on a mains charger) all night and the red light stays on. Then when I try to turn on, nothing happens.

Is there anything I can do or will I have to replace them?

Thanks in advance.

1 Like

Hi @Chris_Sutcliffe , have you tried charging using a different USB cable and/or charging via computer USB port as apposed to a mains USB charger? In the event you have, I would recommend you contact with your order details and they will be able to assist / replace under your 18 month warranty.

1 Like

You can contact for a replacement :ok_hand:

I read on this with others, different things to try:
sometimes holding power button while plugging in to power can reset it.
one guy said try it up to 20 times in a row and it will eventually turn on.
other than that just hit up anker and they will replace them

Many thanks! I just had the same problem and tried holding the power button while plugging in just as you said. After the 4th try it eventually worked :slight_smile:

Cheers, Mat

1 Like

same thing with me, just now I received my soundbuds but when I turn it on, blue color is not showing, ive tried many time as mention above but still no power is coming, I think I have to contact my online store to return it back to them, its very frustrating…

1 Like

Not sure about the sports but the tags have magnets on the insides to attach them together. They will not turn on if they are connected

Mine worked for about 6 months and died. Tried everything here but I think that´s it. R.I.P.

Hi @Dalton_Matsuo_Tavare, if you purchased them 6 months ago from an authorized re-seller, you’re under the 18-month warranty. Feel free to reach out to with the serial number and your order number. Thanks!

Hi all, those who got their soundbuds replaced, does the problem reoccur?

Mine starting to behave the same, and I’m still able to turn on by chance when connected to plugging in to power source.

But it stopped working when you switch it off and you have to redo the same steps to make it work again.

What is the exact issue are you having with yours?

The same here, yesterday i bought it, first works, let them charge and today I couldn’t turn it on… tried so many times holding the power on and plug it… but Notting happens… what else can I do? Please help me!!!

Please try using a different cable and plug to charge these and report back

I use different cables to charge it, but the same issue… the red light turn on for seconds and then turn off… don’t know what else to do

Are you using a wall plug to charge these or a batterypack

I use my Huawei wall plug, use a samsung cable with my desktop, use another cable from other cellphone but nothing’s change

Ok so you plug it in, the red light comes in and after a bit it turns off… So in theory it should be charged… Unplug it, press the power button for 3 to 5 seconds until it powers on. Occasionally you may have to hold down the power button longer but very rarely should you have to do that. The power button is the multimedia button in the center.

I hold it for almost 1 minute but nothing’s happens =(

Send a message to, let them. Know the issue and provide them with the serial number and order number

I’ll. Thanks @elmo41683 for your help!