Soundbud surge jammed at blued light

I have been using soundbud surge for two weeks now but today while running out of charge i put it into the charger untill it was full. However when i turned on it just jammed at blue light as if it has been paired to my device but it is not. The other thing is that it won’t turn off whe pressing the play key for 3 seconds it won’t even unpair. Tried to connect to power source but it still display blue light. Can someone help me out

Have you tried using a different charging cable? Also to unpair a device to connect another press both the + and - buttons at the same time for 3 seconds. In order to power in/off make sure your pressing the multi use button which is the middle button on the controller

If your still having issues send a message and let them know of the problems you are experiencing. Also supply the troubleshooting steps you have taken, order number and serial number of the headphones.

1 Like

I tried to do all the things you have mentioned but no lucky, let me contact the support team

On another note… I’m currently going through a warranty exchange for my Surges’. The right earbud seems like it is blown out or has a bad wiring connection… The music cuts in and out and has a very bad static noise to it. They’ve lasted me 3 months.

@elmo41683 @andrewtiangco Thanks for your response. @carlos_john Could you please try deleting the pairing history on your device and then repair the headphones with your device? If not works, could you please contact with your serial number and order number? We will cover an 18-month warranty regarding any quality issue related. Thanks.

I’m having this exact same problem, also about two weeks after purchase. They were great for those two weeks, though… :frowning:

Having the exact same problem. After the very first charge my Surge headphones are stuck at blue light and are basically dead.

Same here. Let them charge over night and am now stuck on blue light. It doesn’t seem to recognize that charging has stopped.

None of the buttons do anything. Is there a way to hard reset without opening them up?

Press and hold both the volume up and volume down button for 3 to the. Second, this forces a reset and enables pairing mode

Hello elmo,

thanks for the suggestion but the SoundBuds don’t react to any kind of keypress. I will just let the battery run out. That will probably take weeks but it’s less of a hassle than sending it in for warranty replacement.

Hi, having the same problem here with soundbuds curve. Got them, unboxed them, charged them and now I turn them on -> blue light. Pressing + and - doesn’t do anything. Tried to enter pairing mode with 2 sec play button, nothing. The only thing I could do, was to hold the play and + button and it changed to red light (steady light) and when i press + and - in that mode, it sounds like a bell sound, but then nothing, still red. The only thing I can do is to power them off, to turn them on and the blue again. Any thoughts?

I need to know if there’s a solution, because if it isn’t, will get a new one from the seller i think.

You have to hold down the volume up and down button for 3 to 5 seconds, this will put it I to direct pairing mode and also it forgets any connection it has had. Then you should be able to pair it

No man, nothing works, tried that already.

It sounds like you’ve tried the normal troubleshooting steps @Reinaldo_Cortez , you would be best dropping an email with your purchase information, serial and troubleshooting steps taken for further assistance…

1 Like

Thanks! Will do it then.

I had the same problem. For some unknown reason yesterday the soundbuds got stuck at the blue light. Pressing the buttons on any combination or holding them down did nothing.
What I did was just let them discharge on their own until they turn off which took almost a full day. After that just charge them up and they work normal again.

1 Like

I’ve tried a few combinations with different adapters. Basically, the battery in the earphones is tiny and can’t handle high amp output from adapters. Charge from computers or from small adapters. I found the earphones unlock when the battery is depleted. Hope this helps

same problem here. stuck with blue light for days. tried the + - hold button. and hold power button too. What would be the RMA procedure?

I’ve got the same problem. Has anyone found a solution to this?

Still a problem!

Anker, you’re gonna need to include full reset in software or start losing customers!