Sound quality drops to mono with use of Pixel 3

Had an iPhone and everything worked fine. Have a new Pixel 3XL and when I connects to Roav Viva I get a “connection confirmation” through all speakers. However, anything I want to play through the Roav comes out in mono. If I play music through Google, or from a phone app, all works fine. What’s up?

I should also state I was shipped a replacement and still have the issue.

First, pull down the notification panel and tap the gear icon.
From there, find the “Accessibility” entry.
In this menu, find the “Mono Audio” option and toggle it off

Alternatively you can go into developer settings, usually needs to be enabled first on your phone… You can Google how to enable it, then go to Bluetooth audio channel mode and make sure it’s on Stereo.

1 Like