Sondcore liberty air case not charging

I just bought the liberty air wirless earphones 3 days ago and i am using it since then but when i wanted to charge it today, the case is not charging when i put it on the charger and the led lights on the case is not lighting any more even when i disconnect the charger and oen it.
Also another strange thing happened. Although the case itself is not charging the earbuds are still working with almost half the battery and when i connect them to my phone and put them back in the case the connection is still on and they ate continue to work even when they are in the case which suggest a malfunction in the case itself…

Any suggestions or advice on this issue? Have any one gone through this before?

It’s possible that the case is still charging, but the LEDS aren’t working…

You could try using the earbuds for until they die- and don’t put them in the case. Then try seeing if they charge when inserted in the case…

They even do not increase in battery… Ny phone shows that they are 30 % and i put them in the case fir about 30 min and then i connected them again and they are still 30 % so do i still need to empty them first?

No need to be empty them then…

Make sure you removed the plastic covers on the earbuds… if you didn’t, then they won’t charge.

If that isn’t the case (pun intended) then try cleaning them. You can learn how to do that here.

If that doesn’t work, try contacting support at

Good luck!

What kind of charger are you ysing to charge these? Also ha e you tried using a different cable?

The reason the airbuds did not turn off is that the case doesnt have any power to initiate the charge on them which is what turns them off. In the meantime until you get the case charged, tap and hold on the controls for each earbud and force them to turn off that way. This way you dont lose any charge on them.

I tried its cable and my phone cable too and also tried 3 different chargers… Should i try more? Any recommended charger should i try to use?

Think @tank was taking about which adapter block did you use :wink:

I tried 3 of them… One for the iphone and one for the huawei mate 20 pro and another regular one which i use for a Samsung note 2 and they are working properly on all devices

Did you check the charging port for lint?

Yes i checked and no lint or visible dust seen

Take a paper clip, fold it in a way so you can short the two pins on the left earbud side in the case, this will reset the case and then try to charge it again and see if it starts to charge. If that doesnt work then send a email and let them know the troubles you are having

Is there any video for this step as i think i do not understand it clearly?

Inside of the charging case there are two little receptacles that the liberty air touch… can you find these?

If so, then you need to turn a paper clip into a “u” shape, so one of it touches one receptacle, and the other end touches the second receptacle. This will short the case, and reset it.

Do you understand now?


We are sorry to hear your Soundcore Liberty Air is not working properly. According to the information you described, the issue you are experiencing is very unusual. Please try the following steps to see if it helps at all.

For the charging case, please try to use a different charging cable or adaptor to charge it at least 3 hours to see if it helps at all.

For the earbuds issues on charging. Please try:

  1. Let the earbuds be recharged inside the charging case. Note: after the earbuds are fully charged, the steady white light on the earbuds will shut off.
  2. Take the earbuds out of the case and see if a flashing white light comes on. If it doesn’t, try manually pressing the button or touchpad of the earbuds to power them on.
  3. Try to use a terrycloth/cotton swab with a bit of alcohol to clean the contact pins both in the charging case and on earbuds to ensure a better connection.

If the issue still persists, don’t worry, please don’t hesitate to contact us at by detailing your order number and the problem you come across. We will reply you within 24 hours.

I had the same issue with my 5th pair of this replacement earbud now, the only way I got it working is fiddle with the position of the earbud until the led comes on. That is pushing it in or rocking it left, right and back. If that doesn’t help your best bet would be to return this and get a replacement…

Dear Anker support,
I’ve experienced the same issue.
It does not charge. It’s been less than 2 weeks since I purchased this through an agent in Sri Lanka.
The light indicator does not even light when put in the case. The case is fully charged and shows three lights.

What can I do? Thoroughly disappointed at this.

1 Like

Hey Anker support team,

I got the same problem. Really frustrating. Bought it 2 weeks ago.



Got the same issue here. Bought more than a week now and the left earbud doesn’t consistently charge. Even by living it overnight on the charging case connected to usb-c wont add any juice on the bud. Also having the auto on issue when taking the left bud out of the case. Everytime you’ll need to turn it on manually to make it work which defeats the purpose on auto connect function on your device.

I’ve already contacted sopurt and they’ve been fast and helpful on their reply. Just hoping they can help me with my claim.

1 Like

Same issue here. Mine are pretty new too.

Sooo pretty much what I’m hearing from Anker is that there is no solution. Please!! I like these headphones but I’m about to just get the warranty on them because I have the same problem.

They stay connected to the phone while in the charger. They don’t charge in the charger. I’ve moved them around and they are just not charging. The light does not go on at all for the right bud, sometimes left bud will stay on. When I jiggle right bud around, it flashes two times. What is wrong? Is there just no contact to the charger?

Please Help!