(Solved!) Roav Bolt Not Triggering Google Assistant

!!!Solution to this problem (by user Jeremy_Fairbanks) is at the bottom of this post!!!

I paired my HTC U11 with the Roav Bolt via Bluetooth and run through the Google Assistant ‘setup wizard’; selecting to use AUX with the car stereo. All of this completes successfully. Music plays fine from the phone to the car speakers (quality isn’t the greatest, however). Phone calls use the Roav Bolt as the mic and output just fine to the car speakers.

Saying “Ok Google” or “Hey Google” does NOT trigger the Roav Bolt at all. Ever. Pressing the button on the Bolt does not trigger the Google Assistant at all. However, triggering the Google Assistant on my phone manually via pressing the mic button in the app WILL trigger the expected green lights on the Roav Bolt and listen for voice commands.

I’ll take any advice you might have. I have tried using the latest version of the ‘Google’ app and even the latest beta version of that same app. No avail. I’ve reset the Roav Bolt by holding down the button and letting it go ‘blue’. Re-pairing doesn’t change the above-mentioned outcome.

I’ve opened a ticket with customer support, email transcript below:

roav support team support@goroav.com
Apr 23, 2019, 1:35 AM (2 days ago)
to me

Thank you for contacting ROAV customer support. Please be assured we always stand behind our products and want to make this right for you.

We really appreciate your support in our Roav Bolt pre-order campaign. Sorry to hear that the connection is not working well with your htc u11.

_We sincerely sorry to let you know that we are still waiting for the newest firmware upgrade from Google to fix the pairing issue. _

To address your concern, the Roav Bolt does support the Google beta version for the Android device. You may join the Google beta test (click the google download page in the play store to join the beta). You can download the latest on your phone, hereby attached the video as the reference for you.

Sorry for the inconvenience caused. Please keep us updated on how the beta version works.

If you need further assistance, please don’t hesitate to contact us at any time.

Thanks again for your support! Looking forward to your reply.

Warm Regards,
Reference Ticket#64760706 if contacting a CSR


Roav Customer Support Engineer

If you don’t feel satisfied with our response then please click this link to escalate the ticket. A member of our management team will get back to you within 24 hours (Mon-Fri).

Attachments area

Apr 23, 2019, 7:38 AM (2 days ago)
to roav

Unfortunately, I’m already a beta tester for that app. Any idea on when a firmware update will be ready? Should I return the product and wait until then or is it sure to fix the issue? (I don’t want to lose my return window to Best Buy, which is where I purchased it from)

2 Attachments

roav support team
Apr 23, 2019, 10:57 PM (2 days ago)
to me

Dear Alex,

Hope this email finds you well.

This is Cherry from Roav customer support.

We are writing this email to let you know that the latest official Android Google app has been available for your mobile devices.

Please upgrade the app and try the Roav Bolt device again, we have tested on our device and it does fix the pairing issue.

We sincerely apologized for this user experience caused by this issue. Please be assured we always stand behind our products and want to make this right for you.

Thanks again for your patience and support. We are looking forward to your reply.

Best Regards,

Apr 24, 2019, 7:35 AM (1 day ago)
to roav

_Are you saying I should use the non-beta version? I’ll try that and report back. Keep on mind: I’m able to pair to the bolt just fine. I can use it to make calls and listen to music. The Google Assistant won’t respond to hey Google or ok Google though. _

Also, the bolt doesn’t seem able to connect to another phone without resetting it completely. Is there multi device support? Also, music sounds too compressed. Is aptx/aptx hd supported?

AttachmentsApr 24, 2019, 8:13 AM (1 day ago)
Even with the latest non-official Google app it still won’t respond to voice commands. Please advise.

Apr 24, 2019, 8:13 AM (1 day ago)
to roav

_Non-beta is what I meant to say. _

roav support team
Apr 24, 2019, 8:32 AM (1 day ago)
to me

Case Escalation

* Other

i have tried the beta and non-beta version of the Google app (as suggested) but Bolt won’t respond to voice commands even though pairing successfully. Calls and music can be routed to the Bolt just fine. I also have additional questions regarding multiple device support and whether the Bolt uses aptx or aptxHD or neither. I want these questions/concerns addressed before I have my return window to Best Buy closes or I’ll be forced to return the product.

roav support team
5:58 AM (14 hours ago)
to me

Dear Alex,

Thank you for contacting Roav customer support.

This is Wendy, the manager of the customer support team.

We are sincerely sorry to hear the issue still persist, please be assured we always stand behind our products and want to make this right for you.

_For the delay response issue, please give the voice command before you hear the “Beep” sound and see if the voice control will work better. _

To address your concern, the Roav Bolt does can only pair with one device at a time, but you can switch the device by preparing with the Roav Bolt. Also, the Roav Bolt support aptx.

Apologized for any inconvenience caused. We totally understand that our product is not perfect. You have our promise that our engineers would work day and night to improve this product and we are glad to have your support and understanding, which would be a huge encouragement for us to seeking continuous improvement.

If you need further assistance, please don’t hesitate to contact us at any time.

Thanks again for your support! Have a nice day!

Warm Regards,

Reference Ticket#64760706 if contacting a CSR


Roav Customer Support Manager

8:00 AM (12 hours ago)
to roav

It isn’t a delayed response issue. It’s a no response issue. I call out to it and even try pressing the button but the Google Assistant never activates. Only way to trigger the Google Assistant is to trigger it manually on my phone by holding the home button down or pressing the microphone button on the screen, which obviously shouldn’t be done while driving and the point of the product.

After all the craziness, the solution was to simply enable the Spoken Notification setting for the Google app. Big thanks to user Jeremy_Fairbanks for finding this fix, dude deserves a trophy lol. Please refer to the following pictures:


Hmm I think I’d be sending it back at this point. Sorry it didn’t work like desired

1 Like

All these are sort of known issues, i am facing the same, but have high hopes since iOS is still in beta.

this is my second one, so far. already exchanged it when the first one was doing the same thing but it’s obviously some kind of software/firmware issue.

Let’s hope Anker can figure it out and make it work right

1 Like

I had this same problem, but fixed it by enabling the Spoken Notifications from the Bolt settings. On my Note 8, I long pressed the Home button to bring up the Google Assistant, then pressed “Roav Bolt-009C settings”, then Spoken Notifications (it took a while for the list to load). then enable it for Google. Voila! It all works now


i cannot hit like on this comment enough! you just fixed my problem. why this toggle setting isn’t on by default or brought up during the setup wizard is mind boggling. thank you so much. i’m going to add the solution to my original post to help others that come across it.

1 Like

Glad you guys were able to get it fixed

That’s an excellent input! I use an iPhone, didnt come across this setting, will explore later today

Doesnt work for me - and i have tried all the suggested above - with enabling the notification access for Google.

The MIC is just not picking up the wake words. LEDs do not light up. Bluetooth is paired successfully and I can hear the test tones through my bluetooth speaker.

FWIW - I am using a Samsung Note8.

I have sent a email to support and yet to have a response. Anyone ?

Can someone confirm the GOOG Assistant app needs to be open and running before this would work ? I have it running and it still didnt work.

Glad it worked for you.
I’ll be getting one soon and will remember to adjust the settings as per your instructions :thumbsup:

Same here…doesnt work for me Same Note 8 device and spoken notifications are emabled. The trigger word is not working at all. Recieved the package today and installed the latest firmware during installation.

This is not expected as pre ordered and waited for more than 6 months for the package.



Same issue, and the suggested fix did not work for me. I hope this a software issue and not intermittent hardware problems/failure. Worked great at first, then “ok Google” stopped registering. I can’t remember if it happened after a software update on my Pixel 3 XL…

I hope they release an update so it can fix the issues you guys are facing

The way the issues keep coming up, I have a strong feeling this is something to do with hardware itself… Hope they don’t need to replace the bolt devices

I also have a note 8 same problems unfortunately. Extreme delay if it hears me at all. Absolutely silent car. I’d say it hears me 1 out of 20. Phone used to hear me just fine. If I press the button and ask something it will take super long to respond. Forget sending a text it just gives up. Maybe its tired I know I am.

These are the steps that I did and got mine to work.

  1. Forget Roav Bolt as a Bluetooth device
  2. Go to Settings>Storage & Memory>Apps>top right 3 dots>Show System Apps>Bluetooth and clear the data for this.
  3. Uninstall and Reinstall both Google LLC and Google Assistant
  4. Hold down the button on the Roav Bolt for approximately 12 seconds or until the Amber lights progressively all light up.(This factory resets the Roav Bolt)
  5. The lights should then turn blue (This is pairing mode). Pair the Roav Bolt with your phone and follow the setup guide.
  6. After the Roav Bolt it set up open Google Assistant> Roav Bolt settings>Spoken Notifications and verify that Google and Google Assistant spoken Notifications are on.

If this still doesn’t fix your Roav Bolt you might have a defective device. I would suggest contacting either who you bought it from or the manufacturer in order to get a replacement.

1 Like

Yep, for the most part this worked! Thanks! I still ended up having to hold the assistant button down for 10-15 seconds to rest it and hook it up again.

if you hold assistant button on bolt for 12 sec it will factory reset the device. you can start fresh after that.

this is good bit of information, did you receive these steps from Roav Support or figured it out yourself with testing