Small issue with Powercore II 6700

First let me say this issue doesn’t always happen, only once in a while. After charging the Powercore II 6700 to full charge (six dots on the led wheel) I would plug my iPhone X in to charge. After charging 1% the power bank would stop and have lost one of the dots on the led wheel. This could then happen another time after charging the next 1%. Powerbank stops and shows only 4/6 dots. Then it starts charging continuously. Has this happened to anyone else? I like this power bank a lot and I didn’t think much of this when it first happened but now it’s happened a couple of times. Any ideas?

Have you fully charged it to where the led lights go off fully, or are you disconnecting it from power when the last led light is still flashing?
Also have you tried using a different cable to see if it still happens?

Yeah I fully charge it until the lights go off every time. I use the powerport II to charge it and have tried using multiple different anker lightning cables but I still occasionally have the issue I mentioned.

Hmm send a message with the issue and they will walk you through some troubleshooting steps, provide them with your order number and serial number to expedite the response

1 Like

Just emailed Anker, hope to hear back from them soon!