Robovac L70 mopping failure

I recently updated my robovac’s firware to 0.11.30. Everything seemed OK, until I set the device for mopping few days after FW update. Even though tank is full, it keeps alerting me that it is empty and is not wetting the mop as well… Pump inlet and connection seem to be OK. Is there anybody else with the same issue? Can I downgrade the FW in order to see if this is related to FW??

1 Like

Have you tried a software reset.
The howto should be found in the manual.

1 Like

Did not try any reset so far… Will do that…

I dont know how to reset this model.
What always helps with of of those items :
Open the battery case, unplug the battery for 15sec and connect these again.
May be that helps-
Otherwise you will get help from the support.

Very few members here owns L70, (I don’t know any one that owns it), so it’s hard to get an answer from fellow members here.
Please reach out to

I have the same exact issue. After the 0.11.30 update my L70 mopping no longer works, keeps throwing up an error about the tank being empty, absolutely no water is coming out to wet the mop.

I’m having same issue. Any member figured out how to solve it?

I have the same issue all of a sudden after the device worked fine for more than a year. I can’t tell if it’s related to a software update issue. Any way on figuring out if it’s related?

The “water pump” makes a strange noise, as if trying to pump water from an empty tank. The tank is full however. Are you experiencing the same behavior?
Eufy won’t offer any real support for this issue other than stating the device “seems defective”.

Yeah, my L70 makes an electronic buzzing every time when it (I assume) is trying to pump water.

There was recently a new firmware update. This issue started with mine with 0.11.30. Last week firmware 0.11.32 popped up so I installed it. I had hoped that update might include a fix for the issue. Alas, I just tested it, and no luck.

Hi, where did you get the firmware update 0.11.32? I still have version 0.11.30.

I’ve 0.11.32 L70 and it’s not mopping too. I check the water parts and seems no problem with that. I don’t know how to downgrade firmware. I’m looking for help, too.

May be its calcifications.
You could try to add some decalcifier.

Eufy support says you cannot use any products, so I’m not doing that, it could ruin the vacuum cleaner.

Did anyone get a decent response from support regarding a possible software issue?
I’ve tried several times, but the only response I get is that it seems defective :smirk:
Too bad since it’s only a little over 1 year old.

I just purchased a brand new Eufy L70 today, and I am getting this problem. Vacuum works fine, but mopping doesn’t work at all, I get the insufficient water error. There are no blockages. Firmware is 0.11.32

I dont have that mopping version.
Please ask the EUFY support.
You could do a reset by removing the battery for ca 20 secs an insert it again.
often helps
But because you have a brand new item the support is the best to get help!

I have 0.11.30, the app say there is no new firmware, so seems like 0.11.32 was removed from the server.

Anyway, my l70 had the same issue after months of not using the mopping feature.

My solution was a little help for the pump. First I used an straw about the same size of the water inlet in the vacuum, to blow away any debris on the water sprinklers on the bottom. Then I carefully filled the inlet with water, to avoid the pump suck only air. Then I placed the filled water reservoir.

The only thing I don’t like is the fact the robot will throw some water to the floor if you remove the mopping accessory and the water from the reservoir, because there is still water inside the pump but no water in the tank to keep it inside.


Has anyone found a solution? I have the same problem and think its because of a firmware/software update! Does anyone know how to downgrade the software! I don’t find anything in the manuel! Thanks!

I have the same issue. FW is 0.11.32. Water pump tries to buzz periodically but no luck. It seams that water pump is stuck.
Fixed it with small soft silicone pipe. Attached one end of the pipe to water intake with pulled up of the other end. Gently pumped several times to push the air through the pump. This was enough to get mopping back.

1 Like

I am having the exact same issue with 0.11.32…I hear the noise like if it were trying to pump, the tank is full, but I got the insufficient water error.