Robovac 35C Rolling Brush Doesn't Work (4 Beep)


Just 2 weeks ago bought a Robovac 35C. It was working pretty good untill 3 days ago.
Rolling brush suddenly stops rolling and device giving 4 beep with solid red light.

Here is what i tried so far:

  • Cleaned the brush as like fresh new
  • Checked every exterior piece for hair and debris. Nothing found.
    - Tried removing the rolling brush. Still giving the error.
  • Opened the entire device and checked the rolling brush motor for seeing is there any hair tangled. But it was perfectly clear.

The weird part is its sometimes working like 10 minutes. But after that it suddenly stops rolling.

Im not sure i can send it for guarantee because i already opened the device. I just want to fix it by myself and i still want too.

Is there any suggestions for me?

ps. I contact with Anker Support but they have no soluiton. They suggested to send it back.

Meanings of Indicators

Off: No indicator
Breathing orange: Charging
Solid blue: Standby / Cleaning / Fully charged
Solid orange: Low power and returning to charging base
Flashing / Solid red + Beeping: RoboVac has an error (this is your case - error)

One beep = RoboVac’s left/right wheel is stuck. Turn off RoboVac and remove any hair or debris from the left/right wheel.

Two beeps = RoboVac’s side brush is stuck. Turn off RoboVac and remove any hair or debris from the side brush.

Three beeps = RoboVac’s suction fan is stuck. Turn off RoboVac, then remove and empty the dust collector. Make sure the suction inlet is not blocked by any hair or debris.
Four beeps = RoboVac’s rolling brush is stuck. Turn off RoboVac and remove any hair or debris from the rolling brush.

have you tried to disconnect the battery? Open the battery case, take off the battery for about 30 secs and connect it again. This should reset it.

There only other thing I can think is a battery issue, keep your purchase proof handy And Contact eufy customer service team via:



EufyHome app->Help->Contact Us->Feedback/Chat/Call us

1 Like

Have you checked the bumper in front?
May be stuck there.

1 Like

Yes, i opened the robot to motherboard and rolling brush motor. Everything seems fine and perfectly clear.

Sometimes its working like there is no problem thats the weird part

Hey there,

Doesn’t matter if its perfectly clear, still giving this error. Even i remove the rolling brush.

I opened the robot like i mentioned above, and i take off the battery. After that it stats working but after 10 minutes of perfectly working, error starts over again.

I already contacted with customer service but they answered as:

We are sorry to hear that this RoboVac now steps with the 4 beeps and a solid red light, even it is running without the rolling brush. In this case, I am sorry that we have no other suitable troubleshooting to fix this problem.

Glad to know Support is already in touch with you.

so what is the next step - are you sending this Robovac back to Eufy, replacement?

I will send it for repair first to service. I wish i can solve it my own ^^

Sometimes even a skilled “tinkerer” has to give up. :smile: