Robovac 30C doesn't broadcast a Wifi SSID during setup

We just bought a 30C to replace our much loved Robovac 11; but I cannot get the thing setup on the app.

I turn it on - sometimes getting the blue flashing wifi logo, sometimes not, and so I hold the launch button for 10 seconds to make it reset and do so - but even when the Robovac is in this state, no matter what I do with the app or any other device I cannot get it to set up.

50% of the time the robovac doesn’t even come up in the app, but when it does it just moans “can’t connect to the Eufy 30C Wifi network - go to wifi settings and connect” … but even manually I can’t, because it isn’t there. Once or twice (over the 4 odd hours I have been trying to do this) a network has flashed up with that name, but it disappears before I can even tap on it. I have tried manually setting it up, but my phone (naturally) says no SSID of that name exists.

So there is literally nothing I can do. I understand what the setup process is trying to do, the Robovac needs to publish a network that my phone connects to to send over my configuration data, after which both devices will switch back to said LAN configuration. Therefore I must deduce there is a problem with the Robovac setting up it’s own network. I don’t see it on any WiFi sniffing device (such as this laptop), so it’s not just my phone.

We have a very well established connected home, great WiFi, I’m using an LG G7 on Android 8, everythgng should be fine; but this bloomin’ robovac will not give me anything to connect to.

It was bought 4 days ago from Amazon, first time plugged in today.


I’d recommend to send Eufy support an email

you are still in return window. if the issue is not resolved just send it back

With my Robovac 15C i did not have to select the robots Wlan ID. Instead i have selected the WIfi the Robo should connect and the EufyHome App could find the robovac without any problems. If you still have problems try to deactive your mobile network on your smartphone. Helped for me.

Thank you all. I have been in touch with … and they have agreed that what is happening isn’t the correct behavior of the Robovac… therefore they are offering an exchange.

However, they are asking me to mail my robovac to an address, and then they will dispatch a replacement (kind of fair enough, maybe) … but the address they are asking me to send mine to is

Sammi Wong
82 seawall road
Cardiff, cf24 5th
United Kingdom

Which is this place, according to Google street view…

And also, is the registered address of some wholesale suitcase business…

To say I am unconvinced by this is to say the least. Has anyone ever processed a UK exchange for a Eufy product? And had to use this address??

I feel like I will post them my £300 vacuum and never hear anything back again… I am exchanging e-mails with “” which I got off the bottom of the unit, as far as I can tell!


1 Like

Hi there,

I know I am way too late for you but this is the first threat I found when I was having the same (or similar) issue. When I found the answer I thought I’d share what worked for me for any future souls that might pass through here.
I could see my Robovac in the app but whenever I tried connecting to it I got an error message that it couldn’t be connected and to go to my phone’s WiFi settings. Resetting the Robovac, router, my phone did nothing. What did help was turning off both Bluetooth and mobile data and only leave WiFi on. Connected on the first try.

Hope this helps someone someday.


Got the same problem, but the Bluetooth off and the like isn’t working!
Again my phone only sees the Robovac network 40% of the time! Anybody else? Any ideas?

1 Like

Thank you for this thread.
My Eufy Robovac 30 is great but I have experienced similar problems.
Mark I: bumper became stuck. Returned it to Amazon
Mark II: couldn’t get the WiFi connection to work. Returned it to Sammi Wong at the above address. Replacement arrived just fine
Mark III: trouble with the WiFi connection, again. Many attempts later, I found this thread. One last try! Uninstalled App. Turned off mobile data. Reinstalled App. Asked phone to find Robo. Yes! App now working. Schedule set up. All good.
Why did this suddenly work? I believe it was turning off mobile data and starting the app afresh.
Best of luck to anyone else frustrated with this problem. I like my Robovac and am thrilled that it is finally working as it should.
Great thread. Thank you

1 Like

Thanks for sharing what helped! To recap for anyone else experiencing this issue:

If your phone can’t connect to the eufy’s Wifi network,

  • Try turning off Bluetooth on your phone
  • Try turning off Mobile/Cellular data on your phone
  • Force close the eufy app and open it again
  • Try moving further away from your router, as it may be overpowering the eufy’s Wifi signal

Hi all. I’m having this problem but still can’t solve it. I’ve done as suggested. (Took an hour)

It helped to switch both the |0 switch on and off, and to hold the power button on the eufy 30c for 10 seconds to reset it. doing BOTH of these finally got the robovac to appear on the wifi list.

But it keeps failing after this stage. It hits 99% connected, then reports a failure. Gone through the three potential steps (didnt get turned off during, wifi is pretty strong here and re did it beside the router, and the password is definitely right.)

After an hour and a half of trying, I’m at my wits end! Been singing the praises of this company for a month and finally sat down determined to figure out this app problem and I’m so frustrated.

1 Like

Make sure your using 2.5Ghz wifi ban and not 5.0 or a combination of both as it will fail as you experienced

1 Like

Thanks for this. Repeated the above with the lower speed broadband and got the same result.

For some unknown reason, clicking 35c (when I definitely own a 30c) let me complete the set up all the way!

1 Like

The post by carmen.wiech helped a lot. I followed his instructions and it worked on the first try.

On my phone, I turned off bluetooth and cellular data and was able to connect to the eufy wifi and finalize my setup. Thank you for your help.

Also, make sure when you start the setup that you are connected to a 2.4ghz network. On my network, I make sure the 2.4 and 5ghz networks have different names. Sometimes, they have the same name and the device chooses which one to connect to. It might be helfpul to change the SSID (name of your wireless) so that it has different names for the 5ghz connection.

Hi there! While this post is almost a year old- I can’t thank you enough for this. I received my G30 edge, and spent over ten hours going through the motions. I followed your advice and boom. Done!

Thank you!

Hi, I realise this is awhile ago, but did you get any response on this. It is really odd - I am also reluctant to send my Robovac back to this address. Was this address correct.

I am too! No matter what I do - and I’ve done everything- it gets to 99% and fails every single time. I’m sure it’s been over 3 dozen tries over 7 days. I never see the eufy network no matter what I do.

And YES. I’ve turned everything off, only used the 2G network, light is blinking slow bla bla bla. It simply will not connect.

I’m having the same issue, no matter what I do, including following all the advice above, no joy. We just replaced our router (split signal exactly as previous one), get to the point where it is trying to connect and it gets to 99% and returns an error. It is so frustrating. It is definitely trying to connect to the 2.4 GHz band. All of our other devices connect perfectly.

It sounds like you’ve already tried the standard troubleshooting. Please reach out to for further assistance. Live chat is also available during the day at:

1 Like

Thank you, I will. As a last resort I switched off my Sky Q box as I know it can act as a hotspot (invisible) just in case it was interfering with the signal but no, 99% and failure to connect.

Had a similar issue and contacted support. They said put your phone on airplane mode and re-enable wifi and that fixed it for me, connected very fast.

1 Like