Robovac 11c no longer connecting to WiFi

We have been using the Eufy Robovac 11c device since Jan 18 without any issues. It seemed to go offline a couple of days ago according to the app. and repeated attempts to set up the device as new has not worked.

It connects sucessfully to the Eufy robovac wifi and then fails afterwards saying “Setup Failed” and to check your password etc. We have checked everything it says (it was working previously) and can confirm that we are using a 2.4GHz WiFi SSID. Before the “Setup Failed” message appears on the app. it does look like it has worked as the WiFi light on Eufy turns a solid blue which indicates connected. But the app. setup then fails and Eufy does not appear in the list. Are there problems with your servers or has the device become faulty?

Please advise.

Sorry to hear you are having issues with your connection. Have you tried deleting connection. Powering off the device and Wi-Fi router?

If you have or try it and it doesn’t work I would contact support. You can reach them at Make sure you have your serial number and purchase date. Also tell them what you have tried. This will speed up troubleshooting process.