Robotic voice with Liberty Air 2 on MacBook Pro

Hi, I am using my Liberty Air 2 on a MacBook Pro 2019 running MacOS Catalina and for a few weeks my microphone is not working well on Zoom or Slack calls, producing a robotic voice that is not possible to understand for people at the other end of the call. In particular, Slack displays a message saying that is switching microphone and audio to the default system device.

I tried resetting the earphones, SMC and PRAM reset, removed all bluetooth devices.

Can anyone help with this issue please?

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Thank you for trying some troubleshooting already, please try the following steps to see if it helps at all.

  1. Use the default phone call and try it with your mobile phone to see if it makes any difference.
  2. Restart the laptop and reinstall the Zoom APP or the Slack calls
  3. Reset the headphones and connect them to your laptop again
  4. Go into your laptop sound settings and select Headphones as Playback or sound output, then save the setting. Please note: Reset your Bluetooth connection by turning off your device’s Bluetooth for at least 10 seconds and then turn it back on.
  5. Click the Recording beside the PlayBack and choose Headset or sound input, then save the setting. After that, please open the Properties window and select the Levels tab

If the issue still persists, don’t worry, please don’t hesitate to contact us at by detailing your order number and the problem you come across. We will reply you within 24 hours.