Roav Viva Firmware Update not taking

Am trying to apply Roav Viva Firmware update 3.1.2 and it downloads ok, viva light turns green and then it just sits at 0%.
Have tried:
Rebooting viva and Phone.
Forgetting Bluetooth and re-pairing to device.
Unpairing Phone from car stereo and unplugging all usb charging cables.
Deleting app and redownloading.
Standing on one leg and making rooster noises.

None of it worked.
Tried the chat with Roav support option in App and no one ever answered.
Anyone else?

1 Like

Hi @bill_rae,
It sounds like you’ve done everything you can to troubleshoot (the rooster noises didn’t work?! :joy:). Please reach out to the Roav team using the contact information below. Thanks!

Phone: 1-800-988-7973, Mon-Fri 9am-5pm (PT)

I think you may be the only one here who had gotten it early, but I would do as @TechnicallyWell mentioned and send support an email

i emailed them

Would like to know how this turns out, since Ill be getting one any troubleshooting tips ahead of time are like gold during setup.

1 Like

Which leg did you stand on? This is quite important. :sunglasses:

1 Like

Both, this morning I tried again but made monkey noises. Still no joy


“SD card trouble start, please format” Sounds like you forgot to push that button in the back. You know that button that you push when you need to update the device. It’s conveniently located on the device so don’t forget to push it next time. :joy:

1 Like