Roav SmartCharge F0 - can anyone get the supposed USB MP3 player to work?

Hi, all - I was looking for an FM transmitter as an alternative player for the car, and the reputation of Anker’s brand made me choose the F0 - it seemed small and fit for what I wanted. But I cannot actually get it to do what I most wanted from it, which is to use it as a USB player for MP3 files.

I plug it in, I can pair it with any Bluetooth device, and play music from that device via the default frequency, or any other, the sound is very good, all seems fine - but the USB doesn’t seem to do anything.

I plug a USB stick with MP3 files, and the F0 doesn’t do anything. I press the buttons, and nothing happens.

I tried both ports, I tried using 2 different USB pendrives (Sandisk’s), I tried putting MP3 and FLAC files on them in sub-directories or in the main directory, I tried different bitrates - and nothing. The Roav F0 doesn’t play them. I don’t know if it can’t play the files, or detect the USB pendrive… or if the device is unable to act as an MP3 player via a USB device.

It was advertised as able to play MP3s from USB devices, even the manual claims so.

(As an aside note, is there anyone with the Roav F3 here, could you confirm if it is able to play MP3 files from a Micro SD card? I wanted the F0 because it was so much smaller than the F3…)

I don’t think F0 support USB MP3 playing

He’s right. The F3 is the only one with a built-in MP3 player.

I see… so it has to be this model, then, to have the functioning USB (and/or micro card?) player:
https://goroav.com/collections/car-charger/products/smartcharge-f3

(By the way, the Anker Roav Charge app from Play Store can’t find the F0, don’t know if it should be able to).

Incorrect, both the F2 and F3 have MP3 capabilities the difference being F2 is capable of reading MP3’s off of a thumb drive (I believe the bottom port) and the f6 only with micro SD

@Gamera
To get MP3s to play on the f2 you will need to place MP3s directly in the root folder and format the thumb drive to FAT32 I believe. I’ll get back to you on that one.

Edit
My mistake I thought you had an F2 not F0 for a minute it’s easy to get confused when these products look so similar. Unfortunately your f0 does not support MP3 thumb drive playback.

1 Like

Don’t need an app for the F0. I have one.