Roav Jump StarterPro keeps beeping when plugged in

When I plug in the Jumper Cables to the Roav it just keeps beeping. Trying to recharge it, the first light blinks for a few seconds, all four lights stay on for about 5 seconds, then all of the lights go off. I’ve tried putting the charging cable into a laptop, a desktop and a wall outlet. Same result. It worked fine let week and was able to jump the car.

Anyone have any suggestions as to what is going on? Thanks.

Thank you for reaching out! @dgum1

If possible, could you please let us know if the device has been fully charged before?

If the issue still persists, please send us an email with the video reference to, we will have the engineering team get you taken care of within 24 hours.

I’m having the same problem—it’s the first time I’m trying to use the battery.

Since my product was not under warranty, they didn’t want to look at it. I did buy another one at a discount. It works fine. Have used many times. Didn’t want to mess with it since it looked very complicated to take apart and put in a new battery.