Roav Dashcam C1 (Parking Monitor staying on even when turned off) Fix

Hi everyone! Ok, so I’ve been having problems with my Dashcam C1’s Parking Monitor coming on even when I have it set to off. I contacted Roav and after going back and forth with Rosa, we found a solution. So, I wanted to share it with all of you that is having the same problem.

Here are the troubleshooting steps…

  1. Make sure your Roav app is updated, there was a recently one a couple days ago.
    2). Go into the Menu setting of the dash cam and check to see what firmware it’s on, the newest one is v7.8.

Eventhough I did do the app update, on my C1, it still showed that I was on v7.6. Therefore, I had to do a “manual” microSD firmware update.

Here’s how…

  1. Go to Dropbox - File Deleted and download the .bin file.

  2. Take your microSD card out of the dash cam and connect to your computer … in my case, a Mac.

  1. Take that FW96658A.bin file and move it into your microSD card’s root … just drag into your card. Note… it should not be in any folder.

  2. Eject your microSD card

  3. Insert the microSD card with that file into your dash cam (make sure that the dash cam is turned OFF)

  4. Connect the dash cam to an external power supply (wall charger or power bank)

  5. On the side of the power button, the red light will come on and blink… let it do it’s thing

  6. After it does it’s own thing (updating), the dash cam will turn itself on and display “Update successfully.”

  7. Now go back to menu and check on the firmware version… you should be on v7.8 now :slight_smile:

That totally solved my problem with the Parking Monitor coming on when I don’t want it on.

Let me know if you have any questions and I’ll try to help you. :slight_smile:

*** Post has been edited… I originally sent you to the Roav site but unfortunately, the firmware in that link is not current, therefore, I replaced that link with another link that has just the .bin file you need. This makes it easier. :wink:

4 Likes

Ohhhhh I forgot to mention… after the update, the wifi network will revert back to the default. So if you want to change your password, you’ll have to go in the menu to change it.

I’m glad to hear this worked! Thanks for sharing the detailed instructions, @Nhi!

1 Like

Bravo!!!.. Great simple fixer upper… Thanks for sharing

1 Like

You’re very welcome. :slight_smile: That problem had been bugging me for the longest time, thought I could live with it but was just so annoying when I had to dismount it to take the C1 up to my apartment. Who wants to see footages of their palm or pocket? LOL… :stuck_out_tongue:

Wow I don’t know that’s hard

The link on the page downloads a file named v7.6…

https://cdn.shopify.com/s/files/1/1517/5210/files/R2110_V7.6.rar?11363039336425483631

Is the filename wrong?

Here’s the file. Unfortunately, I can’t just add it to the post… not allowed. Therefore, I added another link.

1 Like

@nb12sp Thanks for bringing it to my attention. I have deleted that link and replaced it with another. Hope that helps :slight_smile:

Does it fix anything else? I would rather wait for official release.

I actually got that straight from Roav when I sent them an email.

6 weeks later and Anker still hasn’t bothered to fix this firmware update bug. Pretty disturbing you have to rely on other users and unsecured software to get the product to work right. WTF?

Firmware is up to 7.9 now. Anyone know where I can get it? Friend bought new cam and that was on it

Conntact Roav And ask them to send you the current firmware file

Hi Nhi, I’m so glad I found your fix. You made it so easy for us. My ROAV C1 is working again with up-to-date firmware. Thanks so much for sharing.

Hello @Jennifer_F_I_Young You’re very welcome. Glad that I can be of help. We still use our C1. Just picked up the C1 Pro…haven’t play with it yet but so far, I think I’m keeping it in my car and giving the C1 to the hubby ;).

1 Like