Roav DashCam A1 Won't update to 3.2

My A1 won’t update…I have done updates successfully in the past, but not this time…
It gets a little over 1/2 done initializing after uploading to the dashcam, then resets.
When it restarts, it’s still on 3.0 and when I reconnect, the app asks again if I want to update.

I have tried resetting to defaults, formatting the SD card, and even tried updating without the SD card.
Any ideas?

Believe you are trying update over WiFi connected over the phone. Make sure the phone is close to the Dashcam and also has the firmware downloaded (phone needs to have proper / good LTE network coverage)

Have you tried reaching out to Roav Support, they will provide the Steps. In the worst case, they will provide the upgrade software which needs to be copied to the Micro-SD card and Dashcam upgrades from Micro-SD.

Yes, updating over WiFi. The app downloads the update during the process, and the LTE signal is good. I’m doing this with the phone in one hand and the cam in the other, so distance isn’t an issue.
I’ve done updates before…there’s something wrong with this one.

So…this morning, I cleared app data and tried again. Now, it’s happy at 3.0, with no updates available. Either 3.2 was a myth, or Anker pulled the update.

I wish Anker was more transparent with their updates, with at least a “release notes” page somewhere so we could know what’s changing in the firmware. If they have that, I haven’t found it yet.

Thanks for posting the update.

Possibly. Keep an eye, the issue might be posted soon again :+1: