ROAV C1 "Memory Error"

I bought two ROAV C1’s about a month ago… one for my wife’s car and one for mine.

I pulled mine out of my car today to look at some footage and as most know when you unmount the cam from the dash you usually accidentally press the power button and start the recording of a 60 second video.

After one second I noticed a blue error message saying “Memory Error”.

When I put the microSD into my laptop the card was recognized immediately. When the folder popped up I saw it had stopped recording around the 16th of last month:

I am able to copy gigs of files to this card so the computer has no issue writing to it at all… so it is odd the camera is unable to.

The card in question is a brand new Sandisk Ultra 64gb card that is more than capable of handling the 13mbps bitrate the ROAV writes.

When I first got the C1 it gave me an audible PLEASE INSERT TF CARD error because the 64gb cards come formatted exFAT and it apparently can’t handle that. I had to jump through hoops to get the 64gb card formatted FAT32 and then the camera was fine with it.

So I have a few questions…

  1. Why is the MEMORY ERROR error not audible? I would have caught this weeks ago if I heard the camera tell me there was a problem. In my car the only place for the camera is directly behind the rearview mirror and there is no way to see it unless I sit in the passenger seat.

  2. Is the FAT32 limitation possibly the cause of this error? Windows doesn’t even let you format a 64gb card as FAT32 because it is, apparently, a dumb idea in 2017.

  3. Why is there a FAT32 limitation anyway? The new C1 PRO camera suggests you use a 64/128gb card so clearly it does not have the same FAT32 limitation. Can this be fixed in firmware or is it a hardware issue? Also, why does the manual suggest you format any card larger than 32gb “often”? Like I suggested earlier, is a 64gb card formatted to an archaic file system prone to corruption or something?

A dashcam should just silently work every single day and night until, god forbid, you need it. I didn’t buy this to have to babysit the thing. If I wanted a hassle I’d just use my gopro or my xiaomi yi as a dash cam and yank the thing off every time I parked.

Any answers to the questions above is appreciated.

I’m in the middle of pulling all the footage off the SD card and will reformat it in camera to see if that solves it, but even if it does…

What happens the next time this happens? The camera isn’t going to tell me there is a problem… there needs to be some kind of audible message any time there is a problem.

I was using my GoPro Hero 4 Black as a dash cam before I got the C1. What a pain in the butt to have to unmount the GoPro. I never dared leave the GoPro in the car unattended. I do see your frustration with the C1 though.

Here are some things I’ve learned from using the C1…

  1. Before v7.8 firmware, even when I had the Parking Monitor turned off in the setting, dismounting the dash cam would trigger it on anyways… so annoying. Having to go thru “protected” footage of your hand, leg, pocket because it decided to turn on the Parking Monitor (that’s why you were getting the 30 second clips).

  2. As for the memory card, I was and am using a 64GB card. According to the instructions, they recommend that you use a 32GB or less. Anything over 32GB, they recommend that you format using your computer. Well, when I did that, I did get the card error. I’ve ended up just formatting inside the dash cam. So far, that’s work for me. I did talk to Jing from Roav over the phone and they were not aware that 64GB and larger was troublesome in formatting using the computer. She said that it would be passed on to their tech department. I don’t know the outcome of that though. My advice is to just format the card in the dash cam, it seems that it’s more reliable then formatting on your computer. Or maybe, perhaps even give them a ring and see what they say about it. Here’s their number… 1-800-988-7973. When I had the card error, I did get an audible and a pop up on the screen saying to format the card… but then again, I was there when it did that.

There was a firmware update recently, make sure you do that update. I noticed that you saw my other post and inquired about the link I had posted for the firmware… I have updated it to the correct link. Hopefully, that update will fix your problems with the C1 also. :slight_smile:

1 Like

My problem is you can’t format a 64GB SDXC card as FAT32 in a windows PC without downloading 8 different programs that ignore the fact you shouldn’t be formatting a 64gb memory card with a file system from the 1990s. Maybe your windows is different from mine but windows 10 pro 64bit’s format program only gives me the option of exFAT or NTFS… neither are supported by the C1… but the C1 PRO supports exFAT.

Thanks for updating your link. I’ll go update both of our cams and use it to update the other two cams I put in my sister’s car.

I’m actually on a Mac. But regardless, just formatting the microSD card within the dash cam, worked fine for me. Wow, you really invested in the C1 dash cams…4?

odd… i swear when i first got the roavs they wouldn’t let me format the card in the camera. the voice just said TF card failed to start and showed a blue screen. i had to download some weird third party formatting software to format them fat32.

…but i tried just now with an extreme plus 64gb card i use with my gopro and it seems to have worked.

and yeah. it started with the aukey dr01 on slickdeals. i got that for my wife after someone swerved into her lane and tried to hit her head on. then the roav went on sale so i got two and put the aukey in the back window. then her sister saw ours and wanted two for herself.

Did you see that the directions say not to remove the card with the cam powered on? I noticed that you mentioned that you accidentally hit the power when dismounting. Just to be clear might this be the cause? If not I would contact Anker to arrange a replacement unit. Anker please sell kits with fully compatible SD cards to avoid confusion.

Yes, I would never remove an SD card from anything while it was powered on. You can long press the power button again to stop the 60s countdown and shut the camera down.

So after looking into it more, appears the card is dead in an odd way. Apparently microSD cards, when they experience some kind of catastrophic fault, lock themselves so that data can be recovered, but the card is forever locked. You can delete or copy things to the file and windows appears it is actually doing something, but it is not. If you take the card out and put it back in the card is unchanged. You can’t format it either.

It appears either I have a faulty brand new card or the ROAV bricked the card somehow. I have another one on order to see if it works fine or if it bricks the new card too. Really strange too that the card failed so quickly. I installed the cam on 6/28 and it lasted until 7/17, only writing 42.6gb to the card.

1 Like

Hopefully any possible issues with the camera were solved with the firmware update. Most likely a faulty SD card. Let me know how things work out. +AnkerOfficial Maybe in future models some sort of Fail-Safe might help with this problem to ensure the device is powered off before the card can be removed.

Honestly I’m not really worried about a powered on microsd thing. You would have to pull the camera down off the dash, unplug it, and eject the card before you let the 60s countdown expire to do that. It would just have been nice to get a loud MEMORY ERROR message to go along with the bright blue error box that I couldn’t see. At least then if something does fail you’re audibly told every time you start the car.

I do not own a dash cam but would imagine a loud Audible alarm might not work for a few reason the most obvious being that it would kill the battery when exactly and on what repeating schedule would the alarm go off? I believe that a rapidly flashing light visible from both sides to accommodate drivers in the most countries maybe on the front below the screen would do the trick.

I’m not sure you are understanding what is going on without owning one of these cameras. Let me try to explain again.

If you start your ROAV without a microsd card in it:

  • The ROAV audibly says PLEASE INSERT TF CARD and displays a blue box on the screen that says the same thing.

If you start your ROAV with a microsd card that isn’t formatted correctly as FAT32:

  • The ROAV audibly says TF CARD FAILED TO START and displays a blue box on the screen that says the same thing.

Both tell you “Hey, driver! Something isn’t right here! You need to fix it! Your camera isn’t recording!”

When my ROAV encountered this MEMORY ERROR it did not say anything out loud. It powered on and stayed silent, but displayed a blue box on the screen saying MEMORY ERROR which was hidden behind my rear view mirror. If the ROAV had audibly said MEMORY ERROR or TF CARD FAILED TO START I would have taken the camera down and tried to fix the issue. Instead I drove for 2 weeks without knowing there was a problem.

This has nothing to do with killing batteries, a repeating scheduled alarm, or a blinking light.

Touche, I’m going to bow out of this one but still believe a rapidly blinking bright led fault indicator light in addition to your idea for an alarm upon car start would be a huge help. I hope the new SD card resolve your issues.

@nb12sp We are so sorry to hear that the SD card is unable to be used with your Dashcam. You could try the below troubleshootings to see if it helps.
1.Please default the Dashcam first(Menu>Default>OK)
2. Make sure the SD card is at least class 10. Please use the Dashcam’s format function to format the SD card. Steps: Insert the SD card>Turn on the Dashcam > click menu > format SD card> replug SD card > restart again.

If the issue persist, we are more than glad to help you solve the issue. Could you please contact us via the Please provide us your order ID and your current shipping address through the email, we will help you with the exchange ASAP.

Thank you and we are looking forward to hearing from you.

By the way, your sharing is highly appreciated. @Jesse_Hernandez1 @Nhi

1 Like

I like your new logo!

1 Like