Problems Submitting Amazon Reviews

Has anyone gotten this message? I was trying to send in my review for the ROAV F0 and this is what I got:

Interestingly, I can still review other products, even other Anker products. Any ideas about this message?

Was that recently a giveaway product? Same thing happened to me with the Spirit X giveaway, basically I posted my review here (placeholder to show I had done it) and then tried amazon a few days later and it took.

Nope - wasn’t a giveaway. I just bought it on Amazon normally. I’ll check back in a few days and try it again.

Yep, seen this quite a few times in the past for reviews. If you have not physically purchased the item from Amazon (and sometimes even if you have) they often block leaving a review temporarily due to a large number of non verified purchase reviews trying to be submitted…sometimes its also linked to brands i.e Anker…where Amazon knows samples/giveaways are done…which is considered an incentive for a positive review…


I did buy the product - verified purchaser!

1 Like

while it shouldnt be an issue, amazon does some weird things for certain purchases. One last thing, did you use a code for a discount? that might also flag it.

Like I said even with verified purchases…if they have a large amount of reviews being submitted for an item they pause the ability to leave reviews for a few weeks…consider yourself lucky…some users have lost all their reviews (and are no longer allowed to review) because they violated its review for incentive policy…even though they were written several months or years before they even brought it in :confused:

1 Like

No code, just a daily deal.

:anguished: I have actually refrained from reviews for free products for this reason. I only review the ones I bought on amazon. I leave the free or comp product reviews for Anker forums :slight_smile:

1 Like

Agreed! At least you haven’t had your Amazon profile deleted. It would probably be best to wait a few weeks and then try again.

1 Like

I’ve gotten that message for the Roav F0 every time I’ve tried reviewing it. It’s been a couple of months, so I guess I should try again.

Call Amazon directly.
There was a thread we discussed those Amazon issues a lot.
After ALL my reviews had been deleted I was talking to friendly young lady and “Voila” all showed up again.
There might be another of Amazons weird laws you broke, but a call will help more than thousand emails.

1 Like

This happened to me and I couldn’t get into my reviews or leave one for weeks. I had to contact them several times. And of course, they said they would look into it. I kept live chatting with them until they finally release the hold on my account. All they said was I had violated their rules and so I asked what rule I had broken. They couldn’t give me a straight answer. But I agree with you, I think they associate it with product brands that you’ve done a review for in the past that you either got at a discount or free and tagged it. So now, when you do a review, it gets cross referenced with the brand and whatnot. Amazon has been wonky for awhile in general.

1 Like

I’ve had several Anker reviews removed and handful of other products removed even though they were purchased products. I have pretty much stopped reviewing Anker products on Amazon. If I do, I purchase directly from Amazon and write the full review on my personal site or another review site and then add a modified and shorten version to Amazon.

Amazon has gotten crazy with their review policies and yet shady vendors still get their fake reviews posted with and passed by Amazon review approval system.

1 Like

I will always try to write reviews at
These kind of honest and serious investigations of a product help customers a lot.

1 Like

for the moment I didn’t try to do a review on Amazon

I have experienced this a few times, usually around the launch of the product, or deals, influx of unverified reviews. There are a number of flags that block reviewing in an attempt to keep biased reviews off the site. Usually clears up in time.

Never got it.

@ryandhazen maybe you should contact Amazon because this problem is probably an in-site error inside of