Problem with FM on Soundcore Mini

I just obtained a Soundcore Mini and am having a problem with the FM tuning section.
It goes into FM mode and I can scan using the PLAY button, but it seems that pressing
the + and - buttons does not do much of anything at all. Has anyone else had this
issue? Thanks


That sounds (pun) to me you have not plugged in an AUX audio cable into it - that cable is its aerial and so its scanning the entire spectrum and finding nothing and so appearing to do nothing. Plug in something (anything with a length of wire, old bust earphones, etc).


Nice pun! :joy: But actually, you’ll want to plug in the charging cable to use as an antenna (it does not need to be connected to a charging source). Plugging in an Aux cable might switch it to “Aux” mode and turn off the radio. :wink:

1 Like

Thanks, but no, I do have the MicroUSB plugged in, but it seems that
then npressing the + and - buttons does pretty much nothing in terms
of advancing/tuning to next stations.

1 Like

Hi @dxace1, got it. Please try holding down the + and - buttons for 2 seconds or so. This should change the FM station. You can also hold down the “play” button for 2 seconds to begin scanning for stations again.

1 Like

My issue is that despite plugging in the supplied micro usb charger and being outdoors, I can not receive even 1 clear channel. I even connected a 10ft cable to see if it would help receive better reception, but nothing.

you need a bigger antenna :persevere:

1 Like

Well like the solar panel input for Ankers Powerhouse, it has yet to be released yet. From the looks of your picture though it seems to be a work in progress. :joy:

1 Like

Thanks, I will try this, but it’s definitely a frustrating process, because
when you’re ON a station already and you hold down the + or -
buttons, you usually end up increasing or decreasing volume rather
than moving to the next station. Hoping Anker can redesign this
fine speaker to add perhaps a small LCD readout to show frequency
and/or alter the software to make this easier, because it is a nice
feature to have FM capability.


Would be good if a future revision could allow radio to be controlled via LCD panel or preferably via app (to store settings etc)


Do you get a good FM signal where you are using it? I have a Soundcore Mini and the FM reception is brilliant with the charging cable plugged in, but the FM reception is very good where I live

Yes with everythibg else I do. But this speaker refuses to get FM signal. Oh well.

Figured out the issue on this. You’ll need to plug it into power to ensure the FM transmitter in the speaker has enough power to grab an FM signal. Once plugged in hold down the “Play” butting for a couple seconds, it will scan any or all available stations and save them into your speaker. Once it’s done it’s scan (could take a few minutes) you will have the available stations to signal in to. Once scanned you will use the + and - buttons to sort through the stations. You’ll have to hold the + or - button down for a quick second to switch stations, a quick tap turns up or down the volume. Hope this helps as I found no instructions anywhere…

Hi there everyone! I have had my soundcore mini for many years but didn’t realize it had radio function until today. I struggled with the settings and found this thread. But I made it work! Here’s how. (Excuse my bad English)

  1. Restart your speaker. Wait a few seconds before starting it again.

  2. Connect your charger cable into the speaker, without the USB charger adapter you need to charge the battery, you seperate them two. The cable alone will work as an antenna. (See picture)

  3. Press M (Mode) button on the speaker FOUR times (2-3 sec between the pressing)
    You’ll hear a noise, that’s the radio!

  4. Now press in :arrow_forward: 2 seconds on your speaker. (This is how your speaker searches for radio channels.)

  5. Press long :heavy_minus_sign: on your speaker to stop and save a channel. If you are searching for a specific channel repeat step 4 and 5 til you find the right channel.

Disclaimer: Make sure to be somewhere where you know there’s a good radio signal or else you might not hear anything

Good Luck!