Powerwave Pad A2503 not charging after 3 months

My Powerwave Pad worked great from day one, but has suddenly stopped charging. I have tried using different chargers but no change. I bought it from Amazon in Nov 2020. Can you halep me trouble shoot it? If not how can get a replacement? Thanks.

Did you use a different cable and check the sockets are really clean?
Otherwise you could contact the support here.


Make sure that you are using a Quick Charge 2.0 or 3.0 wall charger. Standard charge mode also requires at least 5V/2A - iPhone stock chargers (only 5V/1A) can not supply enough power for PowerWave Pad.

When you put your phone on the pad, do any of the lights come on? If so is it a flashing light or solid color light?

1 Like

Try different cable. It could also be the charger and a different QC2 / 3 9V 2A charger should be tested.

Also turn off your phone, wait, turn on. Some phones just get confused.

Aa other have suggested, use a different cables and charging bricks and make sure the ports are clean. If that doesn’t work then reach out to support