PowerWave 7.5 Stand blinking blue

I have a roughly two year old PowerWave 7.5 Stand. Recently it stopped working, and so I tried switching out all of the other bits - new cable, new (and definitely good) power brick (an Anker PowerPort Atom PD2, definitely plenty of juice). Still doesn’t charge, and just blinks blue constantly (even if nothing is on it) as if it were detecting a poor connection.

Is this a dead device or is there something I can do to reset it? Is Anker likely to support it several years after purchase or is it too old to bother asking them directly?


Mostly up to 18 months. You should check to see how long you had it. May still be under warranty.

If you have any other charging brick I’d recommend giving it a try, if that doesn’t work then do contact support

That Atom PD2 is incompatible, try another. You need a 5V 2A 10W minimum so seek IQ or IQ2 port.

I’m struggling to believe your charger would work as it’s a dual USB PD and do you’d have to use C-MiniB cable which is rare. You probably mean a different charger which if is IQ IQ2 would be a valid alternative.

Was it working with the old charger?
If so it might be the charger you are using.
I would try another charger.

Like the others have suggested, please double-check to see if it is still under the 18-month warranty. If so, please reach out to support@anker.com and they’ll be happy to assist you.

So, the Atom was indeed the issue as Professor notes. I switched to the PowerPort III Nano and it works. I’m not sure I understand why the Atom didn’t work - it’s a 60W total charger so should have 30W to each. (And yes, usb-c to usb-micro.).

To answer a few others - 2.5 years old (March 2018), so out of the 18 month warranty. And the last brick worked fine to charge other things - but maybe it isn’t able to hit a particular wattage anymore, I have not tested in detail how much it’s able to provide.

Thanks for the help!!

1 Like

PD is Power Delivery.

PD ports need to connect to a PD device to sustain a negotiation. The use of the C-B cable does not end in a emarker PD chip so the charger would either not output any power or a low safe power, which was not what the pad would want. The blinking light tells me some power was getting through 5V 1A ???

So the 30W is not relevant for this, it just didn’t want to work in that combination. It might have worked better if you had a C-C cable with a C-B converter as then the cable would pass the PD test.

The Nano is IQ3 which includes IQ2 which is what ideally you’d want for a wireless charger. IQ2 can work without a C cable, it would default to probably 5V 2A which is exactly enough for this pad. IQ2 would work with all pads as it includes QC2 to go to the 15W level.

I know… complicated!

PD goes up to 20V, the 30W typically goes to 15V. You’d not want to push 15V through electronics designed for only 5V, hence PD does not offer all of its Voltage, hence not all its Wattage, unless the other side says it can handle the Voltage. Devices can self regulate taking not all the current offered, but cannot self regulate not taking Voltage offered, that has to be negotiated in advance prior to giving the Voltage, so USB PD cables contain electronics to stop them passing more than they handle.

Glad it worked out.