PowerUser Submission Problem

Hello, I have a problem while submitting the reviews link in the power user page. After entered the links and pressing the “SUBMIT” blue button I get a rectangular warning confirming my submission, and the product goes from the “shipped” state to the “submitted” state. But the problem is when I refresh the page the product returns to status “shipped” with the links boxes blank, again. All this from yesterday. I tried to repeat the operation three times but nothing.
Has this also happened to someone else? How can I fix it?

1 Like

@AnkerOfficial will pick.this up and get it looked at :thumbsup:

Try clearing your history and cache, in case it’s a browser issue. Failing that send marketing@anker.com an email with your issue and Rosa (or one of the team) will get the issue resolved.

It might not be from your end that the problem is coming from. The other day, I accidentally claimed a Power User item but when I contacted Anker, they said it didn’t show on their side. I went back and looked and there was no trace of it neither. But I did get a confirmation that I claimed it when I clicked it accidentally. So, again, it may not be from your end that you are unable to submit your review. I’d give it until tomorrow before contacting Anker. And of course as @ndalby said, contact them thru marketing@anker.com . Hope that helps :slight_smile:

Thanks for the reply guys! Rosa just contact me via mail to solve this issue on the power user page :sweat_smile:


So was it from their end? What was the outcome?

I do not know what the problem might be. Rosa told me to try to insert again the links in the boxes and press submit but nothing was changed. She told me that she checked my profile and got 2 review links of the product … so maybe I think it’s just a graphic interface issue on the power user page. When the problem is resolved I will write it here.

I think it’s just a glitch in the system. I recall posting a reply to a topic and it kept giving me an error message. Only to find out after I refreshed, it had posted my reply 3 times!!!

Solved! The problem was that the article on amazon.it was “out of stock” and the power user review system had come into conflict with the same item “in stock” in another ad always on amazon.it