PowerTouch 10, PowerPort Speed 2 question

First and foremost I love Anker products, so I purchased a PowerPort Speed 2 and a Power Touch 10 to use with my galaxy S8 Plus…So I plugged in the PowePort than hooked up the Power Touch. Get all the right indications that everything is working fine, set my phone down to charge and nothing. Now I am using an Otterbox defender case. Take off the rubber protector and charging starts up. I wanted to test something so I plugged the Power Touch 10 into my computer and place my phone down on it with the full otterbox case together and it charges.

Am wondering if someone can explain to me why I am getting this to happen, I dont want to have to remove my Otterbox everyday in order to charge my phone

thanks for any help possible


Strange! It sounds like it’s an issue with the PowerPort. Just to clarify, have you tried plugging your phone directly into the PowerPort to be sure it’s working? If so, I would shoot support@anker.com an email. They would be more than wiling to send you out another one.

Also note that the PowerTouch 10 is rated just 3.2 stars on Amazon. That’s definitely on the lower end of the spectrum for Anker products. Perhaps it’s not providing enough power to go through the case. I know that sounds stupid.

Honestly, I’m not sure man. Sounds pretty crazy. Have you tried using other wall chargers or just your computer? One thing is for sure: it should work.

Ther is a chance that there was no difference between the computer and the wall charger, and it just happened to be a coincidence that it worked without the case off. If anything, the Anker should be more powerful (by quite a bit). The wireless charger might be inconsistent.

This is the second email I sent to support@anker.com to help figure this out. Figured I would post it with this just in case my first post didnt make since to people


I guess you dont seem to understand what I wrote about the issue I am having. so here I have outlined the tests I did to see what was going on with my issue

and how I was trying to resolve it. This takes place within a couple of days after receiving the Anker Power Touch 10 first than two days later recieving the
Power Port Speed 2… so here are my results and why my curiousity is peeked and unless otherwise noted each test was done with my phone in its
Otterbox Defender case

Test 1

Anker Powertouch 10 plugged into the normal plug in adapter for charging for the Galaxy S8 Plus
results: FAILED to charge

Test 2

Plugged Anker Power Touch 10 into my computer to use it to charge my phone
results: PASSED, charges fine

Test 3

After recieving Anker Power Port Speed 2 I plugged the Power Touch 10 into that to charge my phone
results: FAILED to charge

Test 4

After reading up I noticed the mention of the phone not being able to charge with a case, took the rubber surround of my case off to try
results: PASSED, charges fine

Test 5

Plugged Power Touch 10 back into computer without rubber surround of case
results: PASSED, charges fine

Test 6

plugged Power Touch 10 back into Power Port 2 after putting my Otterbox Defender case back togther, Same results as Test 3
results: FAILED to charge

So after all that my curiousity is peeked since it says on the product description that was shwon to me that the phone will not charge properly while
in a protective case and yet with all the test I have done why is that when the Power Touch 10 is plugged into my computer it will charge with its case on
but when the Power Touch 10 is plugged into the Power Port Speed 2 it does not. So something is up with how it all works since I am not supposed
to be able to charge my phone with the Power Touch 10 and my Galaxy S8 Plus within its Otterbox defender case
accroding to the data you provide and yet I can do so while the Power Touch 10 is plugged into my computer even though it shouldnt

Now to clarify I did purchase the Power Port Speed 2 so when I take my vacations I could take the Power Touch 10 with me and wireless charge my phone

Hope this clarifies things and what I am trying to figure out


1 Like

Still not sure but seems to be an issue with the input of the wireless charger.

So an interesting puzzle.

There are 4 elements here:

  • the case. Qi energy dissipates to the square of distance and any inducting (metal) will largely take most of the energy away, so cases, particularly ones with metal would largely render Qi useless.
  • the cable. Qi will induce energy in everything, including itself and the cable attached to it. The induction will cause whatever is at the other end of the cable to witness an altered voltage
  • the charger. The issue with the Powerport Speed is it has both QC and VoltageBoost, so it will actually respond to the induction voltage induced by the Powertouch
  • The Powertouch.

What I think is happening is you are using a non-shielded cable, either by design or by fault, it is feeding back to the charger a leaking energy from the Powertouch, back to the Powercore, then the VoltageBoost is responding by sending an incorrect voltage back through the cable. So I think you need a better cable. Try a different cable. If you do not own a cable then get some tin foil and make a small hole, then pass the end of the cable near the Powertouch through that hole and seek to seal the hole shut with additional tin foil. Alternatively wrap a magnet around the cable which will radiate induction away as heat.