PowerPort+ 5 Ports USB-C low charging current


I recently bought an Anker PowerPort+ 5 Ports USB-C chargers, and I am using it to charge my Xiaomi Mi A1, but I noticed that if I open Ampere it shows a very low charge current.

I see ~180mA when I use the PowerPort+, but if I am using any other charger I see much higher. For example, I have an older Anker 24W 2-port charger which shows it charges at 580mA, and I have tried a few other chargers which seem even higher than that.

I haven’t really paid much attention to if it actually charges faster when it is showing a higher current. I’ll have to test it. But I was wondering if this is normal? I have tried a number of different cables, and they all show the same results.

PowerPort+ 5 Ports USB-C device has 1 USB-C and 4 Standard USB-A ports with PowerIQ charging

PowerIQ Provides Output of 5V with 6A(2.4A Max Per Port)
For USB PD, the output is 5V=3A/9V=3A and for 15V=2A/20V=1.5A

Which port are you using to charge and How are you measuring the voltage, current.?

The Xiaomi Mi A1 doesn’t support fast charging. So you’ll want to use one of the USB-A ports and not the USB-C port.

The USB-A ports share a max output of 6A. Each port can offer up to 2.4A, but if 3 or more are in use one or more device could see slower charging. If other devices are connected try disconnecting everything, then plug in your phone and check Ampere. If charging looks normal you can play with adding more devices to see what your limit is.