PowerIQ 3 chargers and Google Pixel 3a with Android 11

I have several Anker PowerIQ 3 chargers, both dual auto/cigar plug, and dual wall-warts… they’ve always worked great with all my USB C devices…

the other day I accepted the update to Android 11 on my Pixel 3A phone, and now I can’t use the Anker chargers at all, the phone does all sorts of wierd stuff (complains about incompatible audio devices, maybe it charges for a few seconds, but it stops charging, maybe it does nothing). The phone charges SLOWLY using a ordinary USB A 2.1amp charger, but thats it.

Now of course, google is taking the stance that only their own charger is supported, but thats AWFUL.
for me, I need to charge on the road, I need dual port chargers because I also carry a USB C tablet, etc etc.

Anker, if you could look into this and maybe figure out whats going on with a Pixel on Android 11, that would be awesome.

1 Like

I have the PowerIQ 3.0 charger and Google Pixel 3a on Android 11… Will give it a try… Have not charged Pixel since upgrade.

Have you reached out to Anker Support support@anker.com mentioning this issue?

Hey @jhn.pierce
I have the same issue with the Galaxy S20 Plus.
They require a PPS compatible charger, so I can’t fast charge with my existing chargers without using a different cable and adaptor 🤦🏼

PPS ? Huh. I know about PD.

Sigh. IThe PowerIQ chargers work great on Android 10

1 Like

I guess they must have worked in something.
Samsung say its to protect the battery or some other excuse!
It’ll be interesting to see how @Shenoy gets on with his tests for you.

ok, I have the PowerDrive III Duo in my car and RV, and I have the dual 120VAC version of the same IQ3 thing in my office. using decent quality “CableMatters” brand USB C-C cables,neither of these chargers will work.

never had a problem before Android 11.

upon more testing, i found another ‘2.1 amp’ USB A charger that, with a Amazon Basics A-C cable, seems to charge it medium, just not ‘rapid’. 10 watt vs 18 watt. another supposed "C’ fast charger that used to work would only do ‘charging slowly’ on the status…


Confirmed - Anker PowerPort III Nano fast charges Google Pixel 3a on Android 11, without any issues!!

Please see the video - i used Google Pixel 3a on Android 11, Anker PowerPort III Nano and Anker USB-C to USB-C cable (from Anker Powercore 20000 Essential kit)

@jhn.pierce I would suggest you change the USB-C cable and give it a try

Also reach out to Anker Support support@anker.com

If this post helped you in any way, please mark this post / my post as “Resolved” :blush:

Well, oddly enough, 2 days later, all my chargers started to work with the existing cables I’ve been using all along. I had already tried using a canned air duster to blow out the USB port on my Pixel 3a, and the end of the USB C cables I was using without any change. My Android version shows the same as yours.


Glad your charger and Cable work well for charging on Pixel 3a :+1: