Powerexpand 8-in-1 HDMI attached monitors are not detectable

Connected the 8-in-1 to the USB-C port on my Lenovo Flex5. The hub is recognized and visible in devices. Attached monitors to both HDMI ports but neither can be detected. Tried again connecting to only one port at a time. No change. Monitor(s) are not detectable.

Nothing appears in Display adapters using control panel.

Disconnected and reconnected hub. No change.

Powered down and restarted laptop. No change.

There are no drivers on the Anker support page to download and update.

Other ports on the hub appear to be working correctly. Only the HDMI ports appear to be a problem.

Any ideas on how to get the HDMI ports functioning?

1 Like

Same here, though I’m onto my second unit now and still no better.

The first one I purchased in July worked great for 2 months but then one day it just stopped sending signal to my monitor. Amazon and other platforms are littered with poor reviews, often for the same issue as we are experiencing, a problem with the HDMI output.

If the answer from Anker is as disappointing as the others I have seen on similar threads I’ll be returning mine and trying another brand.

Turns out the issue is that my laptop does not support DP Alt Mode through the USB-C port. Without this the HDMI ports on the Powerexpand will not work.

Disappointing. Now I have to look for an alternative solution.

I have the exact same problem with my second unit, and everything worked flawlessly for a couple of months in the past.

Did you find a solution to your problem? did tech support provide you with a solution?