PowerExpand 8-in-1 display problem

I bought a PowerExpand 8-in-1 recently to pair with a brand new HP Pavilion 14t-dv000 and I am having troubles getting any video output on the 2x Acer CB272U monitors (QHD) connected to it.

The USB port of the laptop is specified as this: 1 SuperSpeed USB Type-C® 10Gbps signaling rate (USB Power Delivery, DisplayPort™ 1.4, HDMI 2.0, HP Sleep and Charge)

The processor is a brand new i5-1135G7 with integrated Iris Xe graphics, which appears to be capable of supporting up to 4 displays at 4k@60hz each.

I thought I should be able to comfortably drive just 2x QHD external displays over this hub? The integrated display is only a FHD display, so it seems well below what the Xe graphics can do?

Anyway, the system recognizes the monitors when I connect them, but the monitors don’t show any signal. I tried lowering the resolution on them to only 1920x1080, but nothing either. I tried connecting just one to the hub, still nothing. When I connect them directly to the HDMI port, they work just fine.

Any thoughts? Defective hub? All the other ports on the hub work just fine, including ethernet.

1 Like

I have the same problem with my second unit plugged into an HP ENVY. everything worked flawlessly for a couple of months in the past.

Did you find a solution to your problem? did tech support provide you with a solution?


I’m about to get mine today and also have an anker hub like that and a MacBook M1 version. I’ll let you know what I see .

Having an issue with mine too. It turns off every time I sleep/restart/plug in my laptop, and then I have to unplug then plug it back in to get it to work. Very frustrating.

Sorry for the late reply. Mine never worked correctly with my monitors. Their support was trying to help, even provided an experimental firmware for me to try, but that also did not help. I found that the problem only happens when the hub remains plugged in to the power supply. I can get the monitors to work reliably when I remove the power supply to the hub before connecting the laptop. Quite annoying but makes it work. So it seems like the hub remains in a bad state after unplugged from the laptop until power is removed entirely, effectively power cycling it.

1 Like

Anker still hasn’t fixed this (been more than 1/2 a year). I just received mine today and it doesn’t work at all with any external display I have hooked up.

It’s also curious that neither USB-A port provides power, and only one USB-C port provides power, yet both USB-C ports on the MacBook Pro M1 provide display and power support. Didn’t see that before I ordered I would not have ordered.

I guess this goes back to Amazon tonight, and I buy an OWC dock instead (which I know will work); happy to pay more for something that is engineered better.

Do let us know…