PowerDrive Speed 2 Survey--Error message

There’s a pop-up on the Anker.com homepage that invites you to participate in a survey for the PowerDrive Speed 2.

Unfortunately you get this error message when you click the button to complete the survey:

Anyone else having this issue or know how to resolve it? Thanks!

1 Like

@AnkerOfficial @AnkerSupport @AnkerTechnical you guys need to release the Google document permission so we can enter this. Please and thank you.


Glad it’s not just me! Hopefully it will be fixed soon!

This happens way too often with surveys sent via email…


I got the same message too.

1 Like

It still gives the same error message

1 Like

Same error message

1 Like

same here…

1 Like

Same I also have this issue…


In case you all didn’t notice, the survey can now be taken and there is no error showing up anymore. Just wanted to let you all know if you missed it

Sorry for the late reply, the issue has been fixed. Thank you for taking part in the survey!

Missed that chance as it no longer pops up

@Dez_S It’s still there. Try this link https://docs.google.com/forms/d/e/1FAIpQLScqpdzHjnZJINbYZJefpekyFrmjQD9oZORPnGuXGp_aJjTd-A/viewform

Just completed the survey. The link works fine now.
@AnkerOfficial - Thank you for fixing it.

1 Like

Thank you for the help

No problem bud