PowerCore Speed 20000 PD, PD cable, Note 8

The is my second charger in less than a week. The first charger would not take a charge. I returned it and got a replacement. Now my second charger has been fully charged and i plug my Note 8 in and it wont charge my Note 8 using USB-C to USB-C cable. It will charge using a USB-A to USB-C cable. It is really frustrating to buy these products from a company with such a great reputation only to have 2 products fail in less than a week.

Did you push the button before you plugged the cable in?

1 Like

The type C port is input and output. To put the type-c port into output mode you have to push the power button before you connect the phone like @joshuad11 mentioned. Otherwise the powerbank will try to charge from the phone or whatever device you have it connected to.

If those tips don’t help the problem is most likely your cable.

Headphones or Note 8… Same thing, right?!

1 Like

Yeah that’s what I meant I was just recommending a pair of headphones to someone and was stuck in headphone mode.

:upside_down_face::+1:

1 Like

:grin: Kinda like me, I’m always stuck in weather mode. :nerd:

1 Like

? That one went right over my head :smiling_face: What is weather mode?

Tracking storms, analyzing model data, trying to predict the future.

1 Like

Oh you meant storm-chaser mode😉

If you ever get one of these bad boys I’ll be your navigator

Horrible movie very cool truck :grin:

Yes, I want this one.

1 Like

That one kind of looks like a Rollie pollie or pill bug but I like Rollie pollie better :joy:

After watching the video I would recommend larger-diameter airlines so it could drop faster.

I’m surprised I’ve never seen an inverted cone shaped storm-chasing vehicle, it would look ridiculous but that is the hardest shape for a tornado to pick up.

1 Like

Any update on the status of it?

@Chris_Renshaw they Probably never pressed the button to turn on the Usb-C output, instead they were drawing power from their phone

yea i just got one so i’m extra curious, that trick about connecting a A-C to reset it is cool. it is akso starting to bother me when people post problems here, get answers or suggestions, but never give an update. I feel like them telling the community if it fixed the problem, and I am not calling out the OP, just in general would help a lot. So someone who runs into the same problem can search for any posts, then resolve it themseves.

I did press the side button while trying to get my phone to charge. That did not work. I put the charger in my desk and a few days later I got it out and decided to try it again and it started working. It was charging my phone correctly until last night. I charged my tablet with it and went to charge my phone and the charger was dead. I tried to put it on charge using an Anker PD charger and a PD cable. I also tried a usb-a to usb-c cable and a different charger. No luck. I will call Anker today and get a replacement.